On Fri, Aug 18, 2017 at 11:27:26AM +0100, Andrew Cooper wrote:
> To avoid breaking the build elsewhere, the l{1..4}e_{from,get}_page() macros
> are switched to using __mfn_to_page() and __page_to_mfn().
> 
> Most changes are wrapping or removing _mfn()/mfn_x() from existing callsites.
> 
> However, {alloc,free}_l1_table() are switched to using __map_domain_page(), as
> their pfn parameters are otherwise unused.  get_page() has one pfn->mfn
> correction in a printk(), and __get_page_type()'s IOMMU handling has its gfn
> calculation broken out for clarity.
> 
> No functional change.
> 
> Signed-off-by: Andrew Cooper <andrew.coop...@citrix.com>
> ---
> CC: Jan Beulich <jbeul...@suse.com>
> CC: Wei Liu <wei.l...@citrix.com>
> CC: George Dunlap <george.dun...@eu.citrix.com>
> CC: Tim Deegan <t...@xen.org>
> ---
>  xen/arch/x86/mm.c          | 151 
> ++++++++++++++++++++++++---------------------
>  xen/include/asm-x86/page.h |  16 ++---
>  2 files changed, 88 insertions(+), 79 deletions(-)
> 
> diff --git a/xen/arch/x86/mm.c b/xen/arch/x86/mm.c
> index 31fe8a1..e862380 100644
> --- a/xen/arch/x86/mm.c
> +++ b/xen/arch/x86/mm.c
> @@ -123,6 +123,12 @@
>  #include <asm/io_apic.h>
>  #include <asm/pci.h>
>  
> +/* Override macros from asm/mm.h to make them work with mfn_t */

They are from asm/page.h.

Otherwise:

Reviewed-by: Wei Liu <wei.l...@citrix.com>

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel

Reply via email to