Honestly I didn't try to change that point but maybe I'm missing something?

Yes, you are missing something. :-)  I told you exactly what I wanted
changed and what I said could remain the same:

By all means, calculate high_mem_end so it's easier to read.  But then,
when creating a new region, set e820[nr].size = add_high_mem, so that
the BUG_ON() that follows actually checks something useful.

Just to be clear, I want the second if() statement to look like this:

+        if ( i == nr )
+        {
+            e820[nr].addr = ((uint64_t)1 << 32);
+            e820[nr].size = add_high_mem;

Ahh, when you're replying this, I also see this difference and realize what you meant. Sorry to this inconvenience and I'll sync this line into my tree :)

Thanks
Tiejun

+            e820[nr].type = E820_RAM;
+            nr++;
+        }

Think about why and maybe that will help you understand what I'm talking
about.

  -George


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to