On Tue, 2015-11-10 at 19:53 +0000, Ian Jackson wrote:
> 
> +sub lv_create ($$$$) {
> +    my ($ho, $vg, $lv, $mb) = @_;
> +    my $lvdev = "/dev/$vg/$lv";

In the original code it was using $gho->{Lvdev}, is this semantic change
deliberate or a rebase-o? If the former then I think it warrants a comment
in the commit message.

> +    target_cmd_root($ho, "lvremove -f $lvdev ||:");
> +    target_cmd_root($ho, "lvcreate -L ${mb}M -n $lv $vg");
> +    target_cmd_root($ho, "dd if=/dev/zero of=$lvdev count=10");
> +    return $lvdev;
> +}
> +
>  sub lv_dev_mapper ($$) {
>      my ($vg,$lv) = @_;
>      $vg =~ s/-/--/g;
> @@ -1692,9 +1701,7 @@ sub prepareguest ($$$$$$) {
>  
>  sub prepareguest_part_lvmdisk ($$$) {
>      my ($ho, $gho, $disk_mb) = @_;
> -    target_cmd_root($ho, "lvremove -f $gho->{Lvdev} ||:");
> -    target_cmd_root($ho, "lvcreate -L ${disk_mb}M -n $gho->{Lv} $gho-
> >{Vg}");
> -    target_cmd_root($ho, "dd if=/dev/zero of=$gho->{Lvdev} count=10");
> +    lv_create($ho, $gho->{Vg}, $gho->{Lv}, $disk_mb);
>  }
>  
>  sub make_vhd ($$$) {

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

Reply via email to