On 10/17/2016 07:12 AM, Ian Jackson wrote:
> Wei Liu writes ("Re: New ipxe tarball"):
>> On Sun, Oct 16, 2016 at 06:10:47AM -0700, Boris Ostrovsky wrote:
>>> Looks like new ipxe tarball disappeared from xenbits:
> It was never there.
>>> ostr:/tmp$  /usr/bin/wget -c -O _ipxe.tar.gz 
>>> http://xenbits.xen.org/xen-extfiles/ipxe-git-827dd1bfee67daa683935ce65316f7e0f057fe1c.tar.gz
>>> --2016-10-16 09:07:20--  
>>> http://xenbits.xen.org/xen-extfiles/ipxe-git-827dd1bfee67daa683935ce65316f7e0f057fe1c.tar.gz
>>> Resolving xenbits.xen.org (xenbits.xen.org)...
>>> Connecting to xenbits.xen.org (xenbits.xen.org)||:80... 
>>> connected.
>>> HTTP request sent, awaiting response... 404 Not Found
>>> 2016-10-16 09:07:20 ERROR 404: Not Found.
>>> ostr:/tmp$ 
>>> I can see the previous version (ipxe-git-9a93db3...) but not the new one.
> The code (AFAICT from looking at tools/firmware/etherboot/Makefile)
> first tries to download the tarball, and if that fails, uses git
> clone.
> Does the lack of the tarball cause your actual build to fail ?

Yes it did but now that I looked at the logs more carefully it failed
because both wget *and* clone failed, the latter was due to DNS lookup
failure, most likely some sort of intermittent error since it didn't
happen on a subsequent build this morning.

But (as you said below) we should be able to fetch the file that the
Makefile references. (I didn't realize it was never put up there because
presumably git clone worked until the DNS hiccup here).


> I think it's probably sensible to retain this "try tarball first"
> arrangement but we should provide a tarball at least for tag mentioned
> in the release versions of Xen.
> Wei, are we expecting to update IPXE_GIT_TAG again ?
> Ian.

Xen-devel mailing list

Reply via email to