>>> On 06.12.16 at 15:47, <andrew.coop...@citrix.com> wrote: > On 06/12/16 11:44, Jan Beulich wrote: >> This once again points out that handle_mmio() is rather badly named, as >> it's about more than just MMIO. Since we have hvm_emulate_one() >> already, I am, however, lacking an idea for a good alternative name. > > As am I. A number of its current uses are not for MMIO at all, and > would ideally go with some further restriction of emulated instruction.
Actually meanwhile I think I have a plan here, which could go together with renaming the function: To efficiently make use of the new .validate() hook the emulator obtains with the PV priv-op patch, I'd like to have callers of handle_mmio() pass in their hook function (and I think we should not make this optional). Jan _______________________________________________ Xen-devel mailing list Xen-devel@lists.xen.org https://lists.xen.org/xen-devel