On 18/07/2022 09:18, Wei Chen wrote:
  static void init_heap_pages(
      struct page_info *pg, unsigned long nr_pages)
  {
      unsigned long i;
-    bool idle_scrub = false;
+    bool need_scrub = scrub_debug;


You have changed idle_scrub to need_scrub, but haven't mentioned this
in commit log, and I also haven't found related discussion in v1. I
am very clear about this change.

The meaning/use of the variable is now different. Before this patch, the variable was only indicating whether idle scrub was enabled (this is configurable by the admin). This was then or-ed with 'scrub_debug' when calling free_heap_pages().

With this patch, we now store the result of the or-ed in the local variable.

This is not something I felt was necessary to mention in the commit message.

Cheers,

--
Julien Grall

Reply via email to