On 28.08.2025 11:17, Jan Beulich wrote: > The present copy_page_sse2() is useful in case the destination page isn't > going to get touched again soon, or if we want to limit churn on the > caches. Just rename it, to fit the corresponding {clear,scrub}_page_*() > naming scheme. > > For cases where latency is the most important aspect, or when it is > expected that sufficiently large parts of a destination page will get > accessed again soon after the copying, introduce a "hot" alternative. > Again use alternatives patching to select between a "legacy" and an ERMS > variant. > > Don't switch any callers just yet - this will be the subject of subsequent > changes. > > Signed-off-by: Jan Beulich <jbeul...@suse.com>
The ERMS series had been pending for so long that I had forgotten that this further change was yet to be done. I think this patch should be considered part of that earlier series. Yet then it may of course require some more discussion to get it into final shape. Would be nice though to have a consistent set in 4.21 ... Jan