On Thu, Oct 09, 2008 at 11:54:56AM +0900, Isaku Yamahata wrote:
> > > - From the boot message, ondemand governor fails to load.
> > >   I'm not sure this error is expected because of my hardware.
> > >   I guess this error case haven't been tested and that it caused
> > >   the above panic.
> > 
> > >From the boot message, the BIOS _PSS information is totally messed up. 
> > >E.g. 1048575us latency is wrong which cause ondemand driver fail to load, 
> > >also 1048575MHz freq is obviously not correct. There are several possible 
> > >reasons of this:
> > - BIOS itself is not correct
> > - Dom0 ACPICA parsing logic is not correct.
> > 
> > If the native linux (e.g RHEL5) works, then I tend to believe this is dut 
> > to the second reason. The dom0 kernel is bit old and bunch of ACPICA fixes 
> > in mainline kernel are not included in dom0. In my case, I also find the 
> > _PSS parsing result in my Hitachi itanium 2 box is not correct. This issue 
> > is fixed after I pulling two patch from mainline kernel (changeset 677 and 
> > 678 in http://xenbits.xensource.com/linux-2.6.18-xen.hg)
> > 
> > Anyway, this is a separate issue. we will try to find other ia64 box to see 
> > if this issue can be reproduced and then fixed.
> > 
> > BTW, is it possible to check in these patch first?
> 
> Yes, I'll try them.

I checked the ia64 linux repo.
It already includes the changeset as 678:3057b932abea and 677:28419b05401c
so that I tested them with those patches.

thanks,
-- 
yamahata

_______________________________________________
Xen-ia64-devel mailing list
Xen-ia64-devel@lists.xensource.com
http://lists.xensource.com/xen-ia64-devel

Reply via email to