Let's see if this has anyone tried ... I am working with Oracle and SAP for
many years - but with RHEL I am not that experienced (not that I don't have
some earlier this-and-there experience with other distros ans stuff ... I
have "converted" my corporate laptop to fedora about a year and a half ago
(not to mention that it was done in a completely M$-oriented atmosphere),
meaning I have a dual boot which I use when I reeeaaally have to - I did it
few times only in this period, and a dozen of booting this corporate WinXP
dung on QEMU/KVM, which works very nice - this year I have decided to use
resources given to me and to start a prototype for migration to RHEL),
though it makes me feel quite confident. Nevertheless, here is my experience
with my first RHEL 5.4 PV DomU - with SAP and Oracle on it:

It works very good, but I am not prepared yet to say excellent. I am
comparing it with Windows Server 2003 EE SP2 HVM DomU on the sam box (with
similar resources given), and with physical Windows Server 2003 EE SP2 boxes
with SAP and Oracle. I have actually made a system copy based on Oracle
RDBMS EE 10.2.0.4.5 database copy of a system and built SAP ECC6.0 EHP3
instance on top of it - TWIMC: I wanted to try the easy way with just RMAN
media recovery on ntfs disks presented on SAN via fuse module - that didn't
work with updated kernel and filesystemio_options=ASYNCH for Oracle ...
anyway that didn't work, neither regular RMAN convert database worked for
some dumb reason on the source database (I will check it on target, later).
So I tried usual (but slow) exp/imp and data pump utilities - that gave
first serious bumps on the ride: ORA-07445, which means trouble for those
who are familiar with Oracle ... I have prepared everything by-the-book, but
I have only omitted:
 - to set limit for maxproc and descriptors (16384,65536) - corrected
 - I have a strange problem with kernel.sem - it should be "250 32000 100
128", but somehow after restart it always returns to default (250 32000 32
128) - I have set it in /etc/sysctl.conf, it looks ok (I will try without
double quotes, though, these were mandatory with sysctl -w)
 - I am testing Zickus' kernels (http://people.redhat.com/dzickus/el5), I
don't feel like making a new PV DomU with 5.3 kernel right now
 - I have started a SR with Oracle metalink - previous things seem to
resolve the issue, but I can not confirm this, yet

HVM DomU prooved to be rock solid - but slow, probably because there aren't
any PV drivers (just to remind, I am doing this on IA64, Itanium boxes !=
x86_64, James Harper will maybe help one day, or even better, pciback module
might become available for this platform).
But now I have a question (maybe there'll be more): I think I see network
throughput on this DomU of around 7000-9000 kb/s (testing by downloading
with ftp and smbclient), which is unlikely the maximum for gigabit network
adapters these itanium blades (HP BL870c) have ... I see xennet module for
eth0 on DomU (ethtool just says link dected), and on Dom0 same test gives
18000-19000 kb/s ... in the xen vm config machine, I just have vif = [
'mac=..., bridge=xenbr0' ] ... though, I have tried rate= and model=...
nothing changed after that. Any ideas, am I missing something ?
Regards,
ZP.
_______________________________________________
Xen-ia64-devel mailing list
Xen-ia64-devel@lists.xensource.com
http://lists.xensource.com/xen-ia64-devel

Reply via email to