Hi All,
        I was trying to do a little work here with systemsim and the
current tip fails to boot.  The problem boils down to the fact we're now
enabling 2 serial ports and the default maple_device.tcl only supplies one.

The error looks like:
---
WARNING: 2089919: Write_Mapped_Memory_Reg: Unknown address: 0x00000000F40002F9, 
length=1
#0      0x81bc643 in <Write_Mapped_Memory_Reg>:../../../bin/systemsim-gpul 
#1      0x80d46cc in <PA_Write_Memory_Effect>:../../../bin/systemsim-gpul 
#2      0x80d5e0f in 
<EA_Write_Memory_Reg_Effect_Part2>:../../../bin/systemsim-gpul 
#3      0x80df2cf in <Store_Memory_Value>:../../../bin/systemsim-gpul 
#4      0x80f5cda in <store_single_register>:../../../bin/systemsim-gpul 
#5      0x80f669b in <semantic_d_store>:../../../bin/systemsim-gpul 
#6      0x816c8ce in <Simple_Advance_PPC>:../../../bin/systemsim-gpul 
#7      0x80a5eb0 in <PPC_Advance_Job>:../../../bin/systemsim-gpul 
#8      0x81f1009 in <job_entry>:../../../bin/systemsim-gpul 
#9      0x81f10e1 in <job_create_exec + 0xa9> 
WARNING: 2610348: Write_Mapped_Memory_Reg: Unknown address: 0x000003FFFFFFFF70, 
length=8
#0      0x81bc643 in <Write_Mapped_Memory_Reg>:../../../bin/systemsim-gpul 
#1      0x80d46cc in <PA_Write_Memory_Effect>:../../../bin/systemsim-gpul 
#2      0x80d5e0f in 
<EA_Write_Memory_Reg_Effect_Part2>:../../../bin/systemsim-gpul 
#3      0x80df2cf in <Store_Memory_Value>:../../../bin/systemsim-gpul 
#4      0x80f5cda in <store_single_register>:../../../bin/systemsim-gpul 
#5      0x80f64be in <semantic_ds_store>:../../../bin/systemsim-gpul 
#6      0x816c8ce in <Simple_Advance_PPC>:../../../bin/systemsim-gpul 
#7      0x80a5eb0 in <PPC_Advance_Job>:../../../bin/systemsim-gpul 
#8      0x81f1009 in <job_entry>:../../../bin/systemsim-gpul 
#9      0x81f10e1 in <job_create_exec + 0xa9> 
---

This patch fixes that.
---
[EMAIL PROTECTED]:~/MAMBO/mambo/run/gpul$ diff -u maple_devices.tcl{~,}         
      
--- maple_devices.tcl~  2006-08-16 13:35:27.000000000 +1000
+++ maple_devices.tcl   2006-08-16 13:35:32.000000000 +1000
@@ -14,7 +14,7 @@
 set uart0_intr 0xa
 
 # UART 1
-set uart1_enable 0
+set uart1_enable 1
 set uart1_start 0x2f8
 set uart1_end 0x2ff
 set uart1_intr 0x9
---

Just a heads up for anyone using systemsim.

Yours Tony

   linux.conf.au       http://linux.conf.au/ || http://lca2007.linux.org.au/
   Jan 15-20 2007      The Australian Linux Technical Conference!


_______________________________________________
Xen-ppc-devel mailing list
Xen-ppc-devel@lists.xensource.com
http://lists.xensource.com/xen-ppc-devel

Reply via email to