Believe it or not I document this warning here:
  http://wiki.xensource.com/xenwiki/XenPPC/Run/XM

so yes it is reproducible.
I think its a side effect from a large initrd and completely a linux bug, in fact you can google where others have the problem.

I believe you would get this from zIamge.initrd without Xen, but sadly I have lost the ability to boot without Xen on my maple.. I'll be taking a look at that later today.

-JX
On Aug 28, 2006, at 10:23 PM, Hollis Blanchard wrote:

On Mon, 2006-08-28 at 22:13 -0400, Amos Waterland wrote:
Using tip of tree xen.hg and linux.hg, I get this when launching a domU:

Freeing initrd memory: 3141k freed
Bad page state in process 'swapper'
page:c00000000075d000 flags:0x0000100000080000 mapping: 0000000000000000 mapcount
:0 count:0
Trying to fix it up, but a reboot is needed
Backtrace:
Call Trace:
[C00000000081BBA0] [C00000000000F844] .show_stack+0x54/0x1f0 (unreliable)
[C00000000081BC50] [C000000000094B60] .bad_page+0x70/0xd0
[C00000000081BCD0] [C00000000009574C] .free_hot_cold_page+0x1fc/0x210
[C00000000081BD70] [C0000000000332BC] .free_initrd_mem+0x10c/0x150
[C00000000081BE10] [C0000000004F08F0] .free_initrd+0x70/0x130
[C00000000081BEB0] [C0000000000092D8] .init+0x168/0x430
[C00000000081BF90] [C000000000028F54] .kernel_thread+0x4c/0x68

The domU completes its boot fine and I am able to run programs etc.

I'm using the dom1 config that Jimi published earlier.

Hmm, I'm not sure what could cause this.

How reproducible is it? Does it only happen once per domU boot? Always
the same address/backtrace? Generally speaking, how old were the builds
you were using before (one day old? one week old?)?

--
Hollis Blanchard
IBM Linux Technology Center


_______________________________________________
Xen-ppc-devel mailing list
Xen-ppc-devel@lists.xensource.com
http://lists.xensource.com/xen-ppc-devel


_______________________________________________
Xen-ppc-devel mailing list
Xen-ppc-devel@lists.xensource.com
http://lists.xensource.com/xen-ppc-devel

Reply via email to