/me shows utter sadness
mapled:~/work/xen/xenppc-unstable.hg/tools/xm-test # ./runtest.sh - d foobar
  (Skipping report submission)
  Running sanity checks...
  REASON: Failed to create domain
  Sanity checks failed
  mapled:~/work/xen/xenppc-unstable.hg/tools/xm-test #

can't get it off the ground, any pointers.
I think I f'ed up patches,, will try again.
-JX

On Oct 1, 2006, at 2:30 AM, Tony Breeds wrote:

On Fri, Sep 29, 2006 at 08:56:54PM +1100, Tony Breeds wrote:
Hi All,
        These patches update the xm-test code to be more easily portable
to new architecture. This focus od this endevour is PPC but I believe
that IA64 also benifits.

<snip>

By way of a quick status report.

With all thee patches applied to tip (7de08aceff6d) I ran:

I build xm-test:
cd xen.hg/tools/xm-test
./autogen
./configure
INITRD="http://ozlabs.au.ibm.com/~tony/xm-test/"; make existing

I created a grouptest/xenppc file which contains most[1] of the
potential tests and pushed the whole xm-test dir (yes it's wasteful but
it's also easy) to my JS20 blade.  Then:
        ./runtest.sh -d -e [EMAIL PROTECTED] -g xenppc xenppc

creates the following report.
---
Xm-test execution summary:
  PASS:  48
  FAIL:  17
  XPASS: 0
  XFAIL: 0


Details:

 FAIL: 01_block_attach_device_pos
         block-attach failed device did not switch to Connected state

 FAIL: 02_block_attach_file_device_pos
         block-attach failed device did not switch to Connected state

 FAIL: 04_block_attach_device_repeatedly_pos
         Device is not actually attached to domU

 FAIL: 05_block_attach_and_dettach_device_repeatedly_pos
         block-attach failed device did not switch to Connected state

 FAIL: 09_block_attach_and_dettach_device_check_data_pos
         block-attach failed device did not switch to Connected state

 FAIL: 01_block-destroy_btblock_pos
         block device isn't attached; can't detach!

 FAIL: 02_block-destroy_rtblock_pos
         block-attach failed device did not switch to Connected state

 FAIL: 05_block-destroy_byname_pos
         block device isn't attached; can't detach!

 FAIL: 06_block-destroy_check_list_pos
         block-attach failed device did not switch to Connected state

 FAIL: 01_block_device_read_verify
         block-attach failed device did not switch to Connected state

 FAIL: 02_block_device_write_verify
         block-attach failed device did not switch to Connected state

 FAIL: 01_block-list_pos
         Failed to verify that block dev is attached on DomainU

 FAIL: 02_block-list_attachbd_pos
         block-attach failed device did not switch to Connected state

 FAIL: 03_block-list_anotherbd_pos
         Failed to verify that block dev is attached on DomainU

 FAIL: 06_block-list_checkremove_pos
         block-attach failed device did not switch to Connected state

 FAIL: 01_memset_basic_pos
         Invalid domU meminfo line

 FAIL: 03_memset_random_pos
         Invalid domU meminfo line

---

You'd certainly expect the block-* tests to fail. I don't know why the
memset tests failed but I'll find out next week when I'm back at work.

[1] I omitted create/destroy, save/restore, network* and the scheduler
tests becuase I know some of them crash the machine, attached is the
    xenppc file I used.


Yours Tony

linux.conf.au http://linux.conf.au/ || http:// lca2007.linux.org.au/
   Jan 15-20 2007      The Australian Linux Technical Conference!

<xenppc>
_______________________________________________
Xen-ppc-devel mailing list
Xen-ppc-devel@lists.xensource.com
http://lists.xensource.com/xen-ppc-devel


_______________________________________________
Xen-ppc-devel mailing list
Xen-ppc-devel@lists.xensource.com
http://lists.xensource.com/xen-ppc-devel

Reply via email to