I pull only from xenppc-unstable.hg and linux-ppc-2.6.hg.  I'm up to date 
with all latest that was pushed to them, and this combo runs on 
systemsim-gpul.  There was a bug(s?) that caused symptoms like you 
mention, but they were fixed by Amos Waterland about 2nd week in December, 
and pushed to aformentioned repositories by the maintainers.  I can't 
quote or vouch for specific changesets.

Mark Mergen

01/04/2007 03:11 PM
Please respond to

Yoder Stuart-B08248 <[EMAIL PROTECTED]>
Re: [XenPPC] systemsim-gpul problems

On Thu, 2007-01-04 at 10:32 -0700, Yoder Stuart-B08248 wrote:
> I've been trying to get systemsim-gpul working with the 
> latest Xen-PPC.
> The last changeset that worked was 7ad4645e7a54 (11/22/06).
> Changeset ce8c1e26b2ae (Early boot memory avoidance improvemnts)
> broke the simulator with the 'Could not allocate RTAS tree' / HANG
> error.
> With changeset 878ce1f78ad3 (Fix systemsim-gpul failure to boot)
> and later changesets the RTAS allocation / HANG problem is fixed
> but the simulator still won't boot into Linux.
> If I compare logs of the working and non-working Xen/Linux runs
> in the simulator, with the current Xen Linux hangs near the end
> of its boot.   Last messages from Linux are:
>     i2c /dev entries driver IPv4 over IPv4 tunneling driver
>     TCP bic registered
>     NET: Registered protocol family 1
>     NET: Registered protocol family 17
> ...then nothing.
> Shortly after this point in the boot is where the RAMDISK is
> decompressed and accessed.  I'm wondering if the boot related memory
> improvements have affected a RAMDISK built into Linux and Xen.

Have you tried attaching GDB to systemsim to figure out what's going on?

> Has anyone else had recent changesets working on the simulator?

I haven't tried simulator in quite some time...

Hollis Blanchard
IBM Linux Technology Center

Xen-ppc-devel mailing list

Xen-ppc-devel mailing list

Reply via email to