Whad'ya know...if you wait long enough it works!
Thanks Mark.


        From: Mark F Mergen [mailto:[EMAIL PROTECTED] 
        Sent: Thursday, January 04, 2007 4:30 PM
        To: Yoder Stuart-B08248; xen-ppc-devel@lists.xensource.com
        Subject: Fw: [XenPPC] systemsim-gpul problems

        Sorry, I should have read your note more carefully.  Yes, my
latest builds do boot all the way into Linux, but the timing is
drastically altered from the past.  There are places in the boot
sequence (and I think what you mention: after protocol family 17 is one
of them) where you must wait a VERY long time for something to happen.
I can't tell you exactly how long, but it took me a while and accidental
inattention to what was happening before I discovered this.  I have not
had time to work on why this is so.  Also, if you do get all the way to
a Linux command prompt, you may conclude it is not responding to
commands.  Just type a command that you think should work (such as pwd),
hit Enter, and then WAIT A LONG TIME.  If your experience turns out to
be like mine, eventually the characters you typed will be echoed and the
command will be executed with proper output, however slowly.  Obviously,
more debugging is needed.  Maybe it's something simple, like some
simulator option for how real time is reflected to the simulated
machine.  Maybe you will be rewarded by a little (or a LOT of) patience
in your next try. 
        Mark Mergen 
        ----- Forwarded by Mark F Mergen/Watson/IBM on 01/04/2007 05:15
PM ----- 
Mark F Mergen/Watson/IBM 

01/04/2007 05:12 PM 

Yoder Stuart-B08248 <[EMAIL PROTECTED]>,
Re: [XenPPC] systemsim-gpul problemsLink


        I pull only from xenppc-unstable.hg and linux-ppc-2.6.hg.  I'm
up to date with all latest that was pushed to them, and this combo runs
on systemsim-gpul.  There was a bug(s?) that caused symptoms like you
mention, but they were fixed by Amos Waterland about 2nd week in
December, and pushed to aformentioned repositories by the maintainers.
I can't quote or vouch for specific changesets. 
        Mark Mergen 

01/04/2007 03:11 PM 
Please respond to

Yoder Stuart-B08248 <[EMAIL PROTECTED]> 
Re: [XenPPC] systemsim-gpul problems


        On Thu, 2007-01-04 at 10:32 -0700, Yoder Stuart-B08248 wrote:
        > I've been trying to get systemsim-gpul working with the 
        > latest Xen-PPC.
        > The last changeset that worked was 7ad4645e7a54 (11/22/06).
        > Changeset ce8c1e26b2ae (Early boot memory avoidance
        > broke the simulator with the 'Could not allocate RTAS tree' /
        > error.
        > With changeset 878ce1f78ad3 (Fix systemsim-gpul failure to
        > and later changesets the RTAS allocation / HANG problem is
        > but the simulator still won't boot into Linux.
        > If I compare logs of the working and non-working Xen/Linux
        > in the simulator, with the current Xen Linux hangs near the
        > of its boot.   Last messages from Linux are:
        >     i2c /dev entries driver IPv4 over IPv4 tunneling driver
        >     TCP bic registered
        >     NET: Registered protocol family 1
        >     NET: Registered protocol family 17
        > ...then nothing.
        > Shortly after this point in the boot is where the RAMDISK is
        > decompressed and accessed.  I'm wondering if the boot related
        > improvements have affected a RAMDISK built into Linux and Xen.
        Have you tried attaching GDB to systemsim to figure out what's
going on?
        > Has anyone else had recent changesets working on the
        I haven't tried simulator in quite some time...
        Hollis Blanchard
        IBM Linux Technology Center
        Xen-ppc-devel mailing list

Xen-ppc-devel mailing list

Reply via email to