Hi

I tried M A Young's precompiled 2.6.37 XEN kernel (under 
xen-4.0.1-6.fc14.x86_64, grub.conf modified.

I have a Radeon card.
I booted with and without modesetting, without success.
I booted successfully with Radeon driver without acceleration.
I'm sending this email from Dom0 :) Speed is as expected.


Here is the bug report:

Plain Radeon without any xorg.conf modifications on Fedora 14:
Initially there was a graphical modesetting based startup.
I switched from graphical startup progress graphics into text mode during boot: 
I could see textual progress messages during bootup.
When X tried to start, Radeon kernel driver caused a page fault, that it 
couldn't handle.
Full kernel stack trace was visible on the screen, and it could be looked up 
with Shift + page up / page down.
Unfortunately I don't have time to take a log via serial port this weekend.

With nomodeset, booting up progressed (disk IO heard), but the screen was blank 
all the time. I initiated a reboot from the keyboard.
With modesetting with the bug, keyboard didn't work. I initiated a reboot via 
reset button.

Here is the xorg.conf's part as a workaround for Radeon driver problem, 
/etc/xorg.conf.d/00-radeon.conf for Fedora 14:

Section "Device"

   Identifier "UseRadeon"

   Driver "radeon"
   Option "NoAccel" "true"
   Option "DRI" "false"
EndSection

Section "Monitor"

   Identifier "MyMonitor"

   Option "DPMS" "true"

EndSection

Section "Screen"

   Identifier "MyScreen"

   Device "UseRadeon"
   Monitor "MyMonitor"

EndSection

Regards,
Marko Ristola



--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to