I sent the following to xen-users, but thought I'd ask the Fedora
folks too.

I am running the OpenSSL s_server/s_time benchmark between two DomUs. The
two DomUs are running on separate machines, and they are the only
unprivileged domain running on their machine. Both machines have dual
core AMD processors, with Dom0 limited to one core using dom0_max_vcpus=1.

I am using xen-4.0.1 and Xen kernel-

When I run

        openssl s_time -connect

I see:

        No CIPHER specified
        Collecting connection statistics for 30 seconds

This command makes SSL connections and prints 't' to indicate success.

The t's are printed quickly at first but then they pause. After a pause,
things continue again and repeat. It seems that s_time processes for
approximately one second and then pauses for three seconds.

The same thing happens when I run s_time in Dom0 but s_server in DomU
(on the separate machines).

When I run both s_server and s_time in Dom0 (on the separate machines),
there are no pauses.

Also, when I run s_time in DomU and s_server in Dom0 (on the separate
machines) there are no pauses.

Does anyone have any idea what could be going on?


xen mailing list

Reply via email to