04.03.2011 19:57, Roberto Fichera kirjoitti:
>>
>> I also read about setting off ethernet tx offload under dom0 via "ethtool -K 
>> eth0 tx off"
>> but it seems not helping to solve anything, at least in my case.
>>
>> Which kind of configuration you made in your side?
>
> I was just able to solve it right now!!! What I do is the ethtool setup like 
> above in dom0
> than afterwards I made a service dhcpd restart and it worked fine at the 
> price of loosing the
> tx offload automatically made by the network card.
>

Great that you solved it.

I had to modify /etc/sysctl.conf so that br0 bridge works as expected.
Here are the network related lines:

net.ipv4.ip_forward = 1

net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.default.accept_source_route = 0

net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-iptables = 0
net.bridge.bridge-nf-call-arptables = 0
net.ipv4.conf.default.arp_notify = 1

Without applying correct values into sysctl.conf network didn't work as 
expected for the DomU.
This isn't a bug though: you just need to find good documentation to get it 
right.

Regards,
Marko Ristola

>>> Regards,
>>> Marko Ristola
>>>
>>> --
>>> xen mailing list
>>> xen@lists.fedoraproject.org
>>> https://admin.fedoraproject.org/mailman/listinfo/xen
>>>
>> --
>> xen mailing list
>> xen@lists.fedoraproject.org
>> https://admin.fedoraproject.org/mailman/listinfo/xen
>>
>

--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to