On Sunday, April 3, 2011 11:39 AKDT, Jon <j...@destar.net> wrote: 
 
> I followed Pasi's setup at 
> http://wiki.xensource.com/xenwiki/RHEL6Xen4Tutorial to configure and a 
> SL6 box. This all worked great and I have a working system. When I look 
> at my bridge with 'brctl show' I am seeing this as the output:
> 
> brctl show
> bridge name    bridge id        STP enabled    interfaces
> xenbr5        /sys/class/net/xenbr5/bridge: No such file or directory
> /sys/class/net/xenbr5/bridge: No such file or directory


I found the answer to this issue in a thread on the xen-users list, John Haxby 
explains the issue here:

http://lists.xensource.com/archives/html/xen-devel/2011-02/msg00760.html

What I did was download this rpm:

bridge-utils-1.2-9.fc13.x86_64.rpm

And did an rpm -Uvh and now I am seeing this on a 'brctl show' command:

 brctl show
bridge name     bridge id               STP enabled     interfaces
xenbr3          8000.001125a5ce44       no              bond0.3
xenbr5          8000.001125a5ce44       no              bond0.5

Pasi, you might want to look into this on your tutorial, 
http://wiki.xen.org/xenwiki/RHEL6Xen4Tutorial or mention what causes the 
"/sys/class/net/<BridgeName>/bridge: No such file or directory" error to appear 
on a 'brctl show'.

While my system still worked with the errors with no issues, the output was 
ugly to have to look at. :)

Hope that helps someone else,

Jon
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to