On Tue, May 24, 2011 at 4:44 PM, Lefu Ntho <lefun...@gmail.com> wrote:
> Hi guys,
> apologies for posting on xen mailing list earlier,

I replied on that mailing list too, but perhaps my email didn't make it to you.

> I have fc14 running kernel-2.6.35.13-91.fc14.x86_64.
> I did
> $ yum install xen
>
> I would like to compile xend modules with this,
>
> I did steps according to
> http://wiki.xensource.com/xenwiki/Fedora13Xen4Tutorial
>
> $ make -j4 bzImage && make -j4 modules
> $ make modules_install
> $ depmod 2.6.32.40 ( its here where I later run into problems as I do not
> have the right kernel to use, maybe?)
> $ cp -a arch/x86/boot/bzImage /boot/vmlinuz-2.6.32.40
> $ cp -a System.map /boot/System.map-2.6.32.40
> $ cp -a .config /boot/config-2.6.32.40
> $ cd /boot/
> $ dracut initramfs-2.6.35.13-91.fc14.x86_64.img 2.6.32.40

This is the problem. Notice that the two version numbers don't match.
You're trying to update a ramdisk for a 2.6.35 kernel, but you're
telling it to use 2.6.32 modules. That's why it's giving you the error
below.

> Will not override existing initramfs
> (/boot/initramfs-2.6.35.13-91.fc14.x86_64.img) without --force
> $rpm -qa | grep xen
> xen-runtime-4.0.1-7.fc14.x86_64
> xen-licenses-4.0.1-7.fc14.x86_64
> xen-hypervisor-4.0.1-7.fc14.x86_64
> xen-libs-4.0.1-7.fc14.x86_64
> $
>
> is there something I am missing?
> Please point me to the right direction. I will do the rest
>
> Thank you in advance
> --
> xen mailing list
> xen@lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/xen
>
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to