On Sat, Jul 2, 2011 at 12:15 AM, Fajar A. Nugraha <l...@fajar.net> wrote:

> On Sat, Jul 2, 2011 at 10:50 AM, Travis <coras...@gmail.com> wrote:
> > I'm using HVM, and I've attached screenshots from the requested output
> > (+lspci). No other OS is giving me this problem, and
> i'm consistently able
> > to reproduce it. What's your take?
> So no block device detected, and no xen-related module loaded. That's
> weird.
> Two parts of this problem.
> The first part is why would the emulated block device be missing. It
> should still be there if PV drivers was not loaded.
> Are you using the same dom0 (xen and dom0 kernel) and domU config file
> for both the working F14 and F15? If yes, try:
> - "xen_emul_unplug=never" on kernel command line. See
> http://www.kernel.org/doc/Documentation/kernel-parameters.txt
> - make sure you use "hda" on domU config file
> Awesome, the "xen_emul_unplug=never" arg fixed it. I tossed it in and it
booted up and installed just fine. Thanks!!! And the doc you linked
is definitely going in my sysadmin toolbox. Sweet!

> Second part, F15's boot/config- has these
> entries:
> So if you could add xen-platform-pci.ko and xen-blkfront.ko to the
> install initrd, you should be able to use PV drivers directly. Not
> sure what's the easiest way to do it though (maybe unpack initrd, add
> some files, and repack it).

I had tried the fed15 rawhide version from fedora's virtualization-xendomu
test day (april) last night, and it includes the support (it reads the v
disk as a xen device, even) so hopefully it will be polished up (it was
quite a bit rough looking still) and pushed out in the next release/update.

> --
> Fajar
xen mailing list

Reply via email to