Hi, all,

I'm not seeing disks under CentOS 6 when trying to install.  I'm using:


installing using:

virt-install --debug -n sully --mac=02:00:0A:01:01:10 -f 
/var/lib/xen/images/sully -s 12 -r 2048 --vcpus=2 --nographics -p 
--os-type=linux --os-variant=rhel6 --location 

It sounded like:


so I tried dropping the --nonsparse option, but I'm using a newer 
version of python-virtinstall:


than should be required, and I'm seeing this with and with the option 

I do see the disk image is created, and attached to the DomU.  e.g.:

[2011-07-26 01:01:47 18534] DEBUG (DevController:97) DevController: 
writing {'domain': 'sully', 'frontend': 
'/local/domain/18/device/vbd/51712', 'uuid': 
'3380cea8-a322-292d-cc5d-8bb084306976', 'bootable': '1', 'dev': 'xvda', 
'state': '1', 'params': 'aio:/var/lib/xen/images/sully', 'mode': 'w', 
'online': '1', 'frontend-id': '18', 'type': 'tap'} to 

and I can see the disk image if I dump configuration from virsh.

I do see this in the DomU kernel messages:

   XENBUS: Device with no driver: device/vbd/51712
   XENBUS: Device with no driver: device/vif/0
   XENBUS: Device with no driver: device/console/0

but I see reports online that say not to worry about those, initrd will 
load the modules.

The initrd does have:


on it.

I tried adding:


to the kernel parameters per a previous thread here, but that didn't 
seem to change anything.

It seems like others are having success with CentOS 6 in general:


so I suspect it's got something to do with Xen 4.0.2, but I'm not sure 
where to look right now.

Any suggestions?


Bill McGonigle, Owner
BFC Computing, LLC
Telephone: +1.855.SW.LIBRE
Email, IM, VOIP: b...@bfccomputing.com
VCard: http://bfccomputing.com/vcard/bill.vcf
Social networks: bill_mcgonigle/bill.mcgonigle
xen mailing list

Reply via email to