On Tue, 6 Dec 2011, Carlos Felipe Santacruz wrote:

> This is what happened: normally ran 'yum install xen' and that gave no
> problems, but then i rebooted to get to the xen kernel, it resulted on black
> screen (could change consoles with Alt + F2 etc.) so i rebooted and tried
> the regular 3.1.2 kernel with same results. uninstalled xen with 'yum
> history undo' so it would also remove all dependencies then rebooted.
> nothing.
> anyone knows what could have caused this?
> im running f16 x86_64 on an asus g74sx-bbk7(core i7-2630qm, geforce gtx560m,
> 8GB DDR3 ram)

Xen runs the grub2 update script to give you an option to boot the kernel 
with the hypervisor. This is different from the way Fedora handles grub2 
configuration when you add a kernel, as their method doesn't work with 
xen. However there is a risk that you will lose configuration options if 
the Fedora system hasn't set up grub2 correctly. This did happen while 
Fedora 16 was in beta as grub2 overwrote a configuration file when you 
updated it until they fixed it, but I am not sure if this is still a 
problem.

        Michael Young
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to