On Wed, 25 Jan 2012, Roberto Fichera wrote:

On 01/25/2012 10:43 AM, M A Young wrote:
On Wed, 25 Jan 2012, Roberto Fichera wrote:
As I can see the /grub2/grub.cfg contains a valid grub2 configuration.

In pygrub in 4.1 grub gets checked before grub2, and I can't remember if it 
goes on to check grub2 locations if it
finds a grub related file which doesn't work.

Actually I'm under xen-4.0.1-6, should I upgrade it? If so which version do you suggest?

Still doesn't work and the pygrub menu doesn't even come up at all.

Yes, as I already said you need at least the Fedora xen-4.1.1-8 package for grub2 to work. The latest F16 xen should work or you could try backporting pygrubfix2.patch from a recent Fedora xen source package to 4.0.

        Michael Young
xen mailing list

Reply via email to