On Thu, Apr 05, 2012 at 01:11:57AM +0100, M A Young wrote:
> On Wed, 28 Mar 2012, Konrad Rzeszutek Wilk wrote:
> 
> >So with extra="console=hvc0 loglevel=8 
> >root=live:http://build/tftpboot/f17-i386/LiveOS/squashfs.img";
> >
> >I was able to succesfully install, but booting proved interestingly.
> >
> >When trying the 'pygrub' it would complain about the 'No OS loader', but if 
> >I ran
> >it on the disk (pygrub /dev/vg_guest/f17_32) it would extract the payload 
> >properly.
> >(This is with xen-4.1.2-6.fc16). So I worked around by taking those images
> >directly:
> >
> >kernel="/var/run/xend/boot/boot_kernel.jIsJmr"
> >ramdisk="/var/run/xend/boot/boot_ramdisk.I4rBjo"
> >extra="root=/dev/mapper/vg_f17-lv_root ro rd.md=0 rd.lvm.lv=vg_f17/lv_swap 
> >SYSFONT=True  KEYTABLE=us rd.lvm.lv=vg_f17/lv_root rd.luks=0 
> >LANG=en_US.UTF-8 rd.dm=0"
> 
> pygrub works for me via xl. It may be a result of how you are
> booting the guest.
> 
> >And when booting F17 either as HVM or PV, in both cases I got Xorg to
> >tell me:
> >
> >(EE) FBDEV(0): FBIOBLANK: Invalid argument
> >
> >and freeze.
> 
> That seems to be harmless. However I do get the "an error has
> occurred" message instead of the gdm login screen though until I
> removed the fprintd package (and the dependent fprintd-pam package).

Oh, that fixed it! How did you find out that piece of the puzzle?

> 
>       Michael Young
> 
> _______________________________________________
> Xen-devel mailing list
> xen-de...@lists.xen.org
> http://lists.xen.org/xen-devel
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to