On Wed, Apr 17, 2013 at 5:39 PM, sguazt <marco.guazz...@gmail.com> wrote:

>
>
>
> On Wed, Apr 17, 2013 at 4:23 PM, sguazt <marco.guazz...@gmail.com> wrote:
>
>> Hello,
>>
>> I followed this thread on the list archives.
>>
>> I've just installed Fedora 18 and now I want to run the VM images I
>> previously run on Fedora 16 (xen 4.1 + libvirt).
>>
>> So, I would like to know what is the current status of xen/libvirt
>> integration.
>> From the xen wiki (http://wiki.xen.org/wiki/Fedora_Host_Installation),
>> it seems that it is still unsafe to use libvirt with the xl toolstack.
>> But the last update is on Febraury 2013. So some time is passed.
>> Is it still true?
>>
>> Furthermore, do you know what changes one has to do to a libvirt VM
>> configuration XML file that was used to define VM for the xend toolstack?
>>
>> Thank you very much for the help!
>>
>> Best,
>>
>> Hello,
>
> Just to add some other info.
>
> I've tried to use the xend toolstack in the way suggested in the Xen wiki
> and in this thread.
> 1. Disable SELinux (just in case...)
> 2. Removed libvirt-daemon-driver-libxml package (rpm -e --no-deps ...)
> 3. Enabled/started xend via systemctl
> 4. Rebooted the host
>
> After the boot I've done some safety check:
> $ systemctl is-enabled xend.service
> enabled
>
> $ ps -furoot | grep -i xen
> root        31     2  0 17:20 ?        00:00:00 [xenwatch]
> root        32     2  0 17:20 ?        00:00:00 [xenbus]
> root       523     1  0 17:20 ?        00:00:00 /usr/sbin/xenstored
> --pid-file /var/run/xenstored.pid
> root       592     1  0 17:20 ?        00:00:00 /usr/sbin/xenconsoled
> --log=none --log-dir=/var/log/xen/console
> root       705     1  0 17:20 ?        00:00:04 /usr/bin/python -Es
> /usr/sbin/xend
>
> Then I've tried the following command (as root)
>
> $ virt-install -v -c iso/CentOS-6.4-x86_64-minimal.iso --ram 1024 --disk
> path=./images/test-c63_64-xen.img,size=10 --name test-c64_64 --graphics vnc
> --debug
>
> And I got the following error
>
> libvirtError: POST operation failed: xend_post: error from xen daemon:
> (xend.err 'Device 768 (vbd) could not be connected. Hotplug scripts not
> working.')
>
> Any idea?
>
> Thanks,
>
> -- Marco
>
>
Hello again,

I reinstalled Fedora 18 and used the Virtualization Preview Repository (
http://fedoraproject.org/wiki/Virtualization_Preview_Repository).
While libvirtd+libxl still has problems (e.g., I got "error: internal error
libxenlight failed to create new domain"), the combination libvirtd+xend
seems to work.

Actually, I still get problem with virt-viewer but I can live without it by
using a VNC viewer.

I hope to see Virtualization Preview package move soon in the official F18
repository :)

Best,

-- Marco
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to