Thanks for the response, Konrad!

On 03/24/2014 08:48 PM, Konrad Rzeszutek Wilk wrote:
>> It's definitely there in the config file [2] and I can boot it manually.  I 
>> really need the machine to be able to boot unattended.  I tried setting it 
>> manually in /etc/grub/default but that doesn't work either.
>>
>> I'm generating the grub.cfg with grub2-mkconfig > /boot/grub2/grub.cfg and 
>> have re-installed grub2 on my /dev/sda and /dev/sdb (raid-1 /boot).
>>
> 
> Change this:
> GRUB_DEFAULT="saved"
> 
> to
> GRUB_DEFAULT="Fedora GNU/Linux, with Xen hypervisor"

Sorry, that's what I meant by "tried setting it manually in
/etc/grub/default".  I believe this *used to* work.

I wonder if anybody else is successfully booting Xen with f20's grub2?

> That looks like a bug in GRUB. If you use the upstream version of GRUB do you 
> see it?

I haven't gotten far enough along to compile and install an upstream,
but just to note progress, this looks like the commit that started the
option (which seems OK at first glance):

http://git.savannah.gnu.org/cgit/grub.git/commit/util/grub.d/20_linux_xen.in?id=ff99babdfec028ac7211282efe877f3d38a398e2

and here's a general git browser search for xen (not seeing an obvious
breaking commit):

http://git.savannah.gnu.org/cgit/grub.git/log/?qt=grep&q=xen

-Bill

-- 
Bill McGonigle, Owner
BFC Computing, LLC
http://bfccomputing.com/
Telephone: +1.855.SW.LIBRE
Email, IM, VOIP: b...@bfccomputing.com
VCard: http://bfccomputing.com/vcard/bill.vcf
Social networks: bill_mcgonigle/bill.mcgonigle
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to