On Tue, Nov 11, 2014 at 5:43 PM, Konrad Rzeszutek Wilk
<konrad.w...@oracle.com> wrote:
>> Renamed the bridge to 'xenbr0':
>> xenbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
>>         inet  netmask  broadcast
>>         inet6 fe80::219:99ff:feef:62ab  prefixlen 64  scopeid 0x20<link>
>>         ether 00:19:99:ef:62:ab  txqueuelen 0  (Ethernet)
>>         RX packets 8  bytes 1144 (1.1 KiB)
>>         RX errors 0  dropped 0  overruns 0  frame 0
>>         TX packets 8  bytes 648 (648.0 B)
>>         TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
>> rebooted the machine... But same error
> I presume you also changed the entry in the xml file?


    <interface type='bridge'>
      <mac address='00:00:00:00:00:00'/>
      <source bridge='xenbr0'/>
      <script path='vif-bridge'/>

>> Could you be more specific. Sorry, I'm not a sysadmin.
>> I'm using Xen for research purpose
> Edit /etc/libvirt/libvirtd.conf
> and change 'log_level' to be 'log_level=4'
> and make sure that 'log_output' has '"1:syslog:libvirtd"

OK. Changed /etc/libvirt/libvirtd.conf:

log_level = 4

Then rebooted and tried to create the VM with libvirt with virsh.

This is the output of /var/log/libvirt/libxl/testvm.log

libxl: verbose:
libxl_create.c:130:libxl__domain_build_info_setdefault: qemu-xen is
unavailable, use qemu-xen-traditional instead: No such file or
libxl: debug: libxl_create.c:1243:do_domain_create: ao 0x7f713c002a80:
create: how=(nil) callback=(nil) poller=0x7f713c009ee0
libxl: debug: libxl_device.c:257:libxl__device_disk_set_backend: Disk
vdev=hda spec.backend=tap
libxl: debug: libxl_device.c:212:disk_try_backend: Disk vdev=hda,
backend tap unsuitable because blktap not available
libxl: error: libxl_device.c:300:libxl__device_disk_set_backend: no
suitable backend for disk hda
libxl: error: libxl_dm.c:1305:libxl__destroy_device_model: could not
find device-model's pid for dom 3
libxl: error: libxl.c:1420:libxl__destroy_domid:
libxl__destroy_device_model failed for 3
libxl: debug: libxl_event.c:1569:libxl__ao_complete: ao
0x7f713c002a80: complete, rc=-3
libxl: debug: libxl_create.c:1256:do_domain_create: ao 0x7f713c002a80:
inprogress: poller=0x7f713c009ee0, flags=ic
libxl: debug: libxl_event.c:1541:libxl__ao__destroy: ao 0x7f713c002a80: destroy

Don't know if it is OK, but the first row claims about the missing
device model qemu-xen...
Then there are a couple of errors about the disk device back-end and
the device model, but honestly I have some trouble in finding a way to
fix them

In /var/log/libvirt/libxl-driver.log, there isn't nothing of interest (IMO):

xc: debug: hypercall buffer: total allocations:18 total releases:18
xc: debug: hypercall buffer: current allocations:0 maximum allocations:4
xc: debug: hypercall buffer: cache current size:4
xc: debug: hypercall buffer: cache hits:13 misses:4 toobig:1


-- Marco
xen mailing list

Reply via email to