On Mon, Nov 17, 2014 at 10:20 AM, Marco Guazzone
<marco.guazz...@gmail.com> wrote:
>

[big cut]

> Hi,
>
> Any news?
>
> In the meanwhile, from the qemu command above, I've noted that it
> tries to boot from HD.
> In fact, the conversion from Xen config file to XML missed to add a
> <boot> element for cdrom (instead, it wrongly added a duplicate
> element for HD).
> So, I've tried to add this <boot> element, thus resulting in:
>
>   <os>
>     <type arch='x86_64' machine='xenfv'>hvm</type>
>     <loader>/usr/lib/xen/boot/hvmloader</loader>
>     <boot dev='hd'/>
> <!--
>     <boot dev='hd'/>
> -->
>     <boot dev='cdrom'/>
>  </os>
>
> Now, the QEMU command spawn by virsh is
>
> /usr/lib/xen/bin/qemu-dm -d 3 -domain-name testvm -vnc 127.0.0.1:0
> -videoram 8 -boot cd -vcpu_avail 0x01 -net none -M xenfv
>
> Now, vncviewer is able to connect, I can see the CentOS initial menu,
> but when I choose to start the installation the vnc window becomes
> black and I can do nothing.
> I've tried to start the installation in several ways, including the
> basic graphics mode (VESA) or by adding the "text" parameter to the
> kernel boot options.
> But the result is the same.
>

[big cut]

>

Hi,

Maybe, I've found a workaround. I had to change again the XML file in
order to add some 'features' element.
  <features>
    <acpi/>
    <apic/>
    <pae/>
    <hap/>
  </features>

This time, the installation of the guest system seems to work.
I still have some annoying problem with the CentOS graphical
installation since the installation GUI immediately disappears with
the following message:
  ** (anaconda:1049): WARNING **: keybinder_init: Unable to open display
  (anaconda:1049): Gdk-WARNING **: anaconda: Fatal IO Error 0
(Success) on X server :1.
  Pane is dead
and the installation program remains stuck.
I've also tried to start the installation in the basic graphics mode.
But the problem remains.

Again, I can solve this with a workaround: I start the installation in
text mode by adding "text" to the kernel boot options of the CentOS
installation.

Now the VM is up & running.

Best,

-- Marco
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to