On 09/15/2015 05:35 PM, M A Young wrote:
> 
> 
> On Tue, 15 Sep 2015, Cole Robinson wrote:
> 
>> Anyone know how to get fedora + xen running in a KVM VM? I'd like to be able
>> to do basic xen/libxl/libvirt testing without needed to reboot a physical 
>> machine.
>>
>> Trying with F23 AMD host, F22+xen L1, trying to boot into xen in the L1 VM
>> just reboots very soon after trying to boot the kernel. Tried disabling all
>> virtio for L1 VM, disabling virt extensions for the L1 VM, but it didn't seem
>> to change anything. Unfortunately the messages scroll by so quickly I can't
>> tell what's happening right before it reboots, and all efforts to convince it
>> to print more debugging haven't worked.
>>
>> FWIW this does work with rhel5+xen L1, but that's a world away at this point.
>>
>> So anyone know if it's even possible? Is there a trick to it? If not,
>> suggestions on getting more debug output from xen + grub2?
> 
> It works for me after a basic and probably sub-optimal install, as follows
> 
> * qemu-kvm -cdrom Fedora-Server-DVD-x86_64-22.iso -m 1024 -hda kvm.img
> * do a minimal install
> * after reboot dnf install xen xen-hypervisor
> * select "Fedora, with Xen hypervisor" in the boot menu
> 

Thanks, the minimal command line worked for me. It allowed me to track it back
and and find the culprit.

It comes down the -cpu value; the default qemu64 works, but any Opteron_* or
-cpu host do not work. I had played around with this originally thinking maybe
it was a nested virt issue, and tried Opteron_G1 which lacks svm, but never
actually tried the default qemu64 cpu...

So this doesn't work:

  $ qemu-kvm -m 1024 -hda kvm.img -cpu Opteron_G1

However this does:

  $ qemu-kvm -m 1024 -hda kvm.img -cpu Opteron_G1,family=6

qemu64 uses family=6, but Opteron_G1 uses family=15. I see there's some bits
of qemu that trigger off family>6 regarding setting some bits about MCE, but I
tried disabling those in the code and things still errored. More data points:

- TCG works fine for every combo I tried
- cpu qemu64,family=15 fails
- None of this affects my intel host, all these work fine: -cpu host, -cpu
Opteron_G1, -cpu qemu64, -cpu qemu64,family=15

So given all that, anyone have a suggestion of whether this is a KVM or Xen bug?

> If you need more debugging, boot without xen, and edit the grub.cfg file,
> adding console=com1 after xen.gz and replacing rhgb quiet with 
> console=hvc0 in the 'Fedora, with Xen hypervisor' section, then boot kvm 
> with -serial eg. -serial file:boot.log which should give you xen logging 
> after grub has finished.
> 

Unfortunately I couldn't get anything else extra out of xen using any of these
options or the ones Major recommended... in fact I couldn't get anything to
the serial console at all. console=con1 would seem to redirect messages since
they wouldn't show up on the graphical display, but nothing went to the serial
log. Maybe I'm missing something...

sync_console gives an extra message but that's all I could see. Is
console=hvc0 correct for a KVM guest, or is that only going to work for
xen-on-xen ? I tried console=ttyS0 as well but it didn't make a difference

Thanks,
Cole
--
xen mailing list
xen@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/xen

Reply via email to