On Fri, May 20, 2016 at 9:51 AM, W. Michael Petullo <m...@flyn.org> wrote:

> What file-backed disk formats are supported by Xen using a Fedora Dom0? I
> am testing xen-4.6.1-8.fc24.x86_64, and I have not been able to get the
> "qcow2" and "vhd" formats to work. "Qcow" version 1 works fine with:
>         disk = [ "tap2:qcow:/var/lib/xen/images/test-data.xen-qcow,xvdb,w"
> ]
> However, when I try qcow2, the VM detects the disk, but "fdisk /dev/sdb"
> says:
>         fdisk: cannot open /dev/sdb: No such file or directory
> When I try vhd, the VM kernel does not even detect the disk.
> --
> Mike
> :wq
 I also tried to use qcow2 on Fedora-Xen 24.

The disk config is simple:
disk = [ "/XXXX/root.qcow2,qcow2,hda,w",
"/XXXX/Fedora-Live-Workstation-x86_64-23-10.iso,,hdc,cdrom" ]

First, I tried the default packages:

When creating the vm with xl, /var/log/xen/qemu-dm-XXXX.log got some
xen be core: xen be: watching backend path (backend/console/1) failed
xen be core: xen be: watching backend path (backend/vkbd/1) failed
xen be core: xen be: watching backend path (backend/qdisk/1) failed

And the vm timed out to connect to the vbd and the qemu process didn't open
the qcow2 file.

There seems some inconsistency between xen-4.6.1 and the system qemu 2.6.0.
So I tried to
find and use the qemu-xen version from xen tarball. I got one from the
XenServer 7[1]
binpkg.iso[2] and extracted the qemu-xen rpm[3].

Install the qemu-xen rpm with following steps:
1. dnf install libpng15
2. rpm -Uvh --force qemu-xen*rpm

And then in the vm cfg, I added two lines:

And with the vm created, /dev/xvda was seen within the vm.

So, the question is whether we can fix the system qemu to support the
current xen, or just go back to
use the bundled qemu-xen instead of the system qemu.

[3] qemu-xen-2.2.1-4.36786.x86_64.rpm


> xen mailing list
> xen@lists.fedoraproject.org
> http://lists.fedoraproject.org/admin/lists/xen@lists.fedoraproject.org
xen mailing list

Reply via email to