petsc (3.6.2.dfsg1-3) unstable; urgency=medium

  * Add Depends: libssl-dev, libgfortran-5-dev to petsc dev packages.
    Needed since petsc invokes external libraries -lssl -lcrypto -gfortran 
    in <petsc>/lib/pkgconfig/PETSc.pc and <petsc>/lib/petsc/conf/petscvariables
    cf. bug #802706

petsc (3.6.2.dfsg1-2) unstable; urgency=medium

  * Ensure octave directory exists for linking to PETSc matlab scripts.

petsc (3.6.2.dfsg1-1) unstable; urgency=medium

  * New upstream version.
  * Apply Files-Excluded to debian/copyright to exclude DSFG files from
    upstream source tarball:
     - PDF documentation (source documentation is not available)
        - docs/
        - src/ts/examples/tutorials/power_grid/PDF_eqs_power_grid.pdf
     - win32 executables in bin/win32fe (source code is available
       separately at https://bitbucket.org/petsc/win32fe but we don't
       need it and therefore don't include it)
  * Standards version 3.9.6.
  * PETSc matlab scripts are linked to /usr/share/octave/site/m/petsc.
    Closes: #736662.
  * Add superlu support.  Closes: #671062.
  * Provide new packages libpetsc-complex-3.6.2-dev, libpetsc-complex-3.6
    and libpetsc-complex-3.6.2-dbg with support for complex numbers. 
    Closes: #730317.
  * The library and soname are modified for complex support,
    libpetsc_complex.so.  The standard build with real numbers has a
    modified soname to match, libpetc_real.so.  The preference for
    libpetsc.so is controlled by alternatives (petsc and libpetsc.so.3.6).

Date: 2015-10-24 22:16:57.960482+00:00
Signed-By: Logan Rosen <loganro...@gmail.com>
https://launchpad.net/ubuntu/+source/petsc/3.6.2.dfsg1-3
Sorry, changesfile not available.
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to