qemu (1:2.4+dfsg-5ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Update the ubuntu machine types patch to reflect upstream churn
    - debian/rules: do not drop the init scripts loading kvm modules
      (still needed in precise in cloud archive)
    - qemu-system-common.postinst:
      * remove acl placed by udev, and add udevadm trigger.
      * reload kvm_intel if needed to set nested=1
    - qemu-system-common.preinst: add kvm group if needed
    - add qemu-kvm upstart job and defaults file (rules,
      qemu-system-x86.qemu-kvm.default, qemu-system-x86.qemu-kvm.upstart)
    - rules,qemu-system-x86.modprobe: support use under older udevs which
      do not auto-load the kvm kernel module.  Enable nesting by default
      on intel.
    - d/p/ubuntu/expose-vmx_qemu64cpu.patch: enable nested kvm by default
      in qemu64 cpu type.
    - d/p/ubuntu/define-trusty-machine-type.patch: define a default trusty
      machine type to ease future live vm migration.
    - apport hook for qemu source package: d/source_qemu-kvm.py,
      d/qemu-system-common.install
    - Make qemu-system-common and qemu-utils depend on qemu-block-extra
      to fix errors with missing block backends. (LP: #1495895)
    - control-in: build with libseccomp an all architectures
    - Add vGICv3 support

qemu (1:2.4+dfsg-5) unstable; urgency=medium

  * trace-remove-malloc-tracing.patch from upstream.
    (Closes: #802633)
  * stop building libcacard, as it is now in its own separate
    source package and has been removed from upstream qemu in 2.5.
    Here we just stop producing libcacard binaries, but still use
    embedded libcacard source to link with it statically.  In 2.5
    we will switch to external libcacard. (Closes: #805410)

Date: Wed, 02 Dec 2015 21:31:36 +0100
Changed-By: Matthias Klose <d...@ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/qemu/1:2.4+dfsg-5ubuntu1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 02 Dec 2015 21:31:36 +0100
Source: qemu
Binary: qemu qemu-system qemu-block-extra qemu-system-common qemu-system-misc 
qemu-system-arm qemu-system-mips qemu-system-ppc qemu-system-sparc 
qemu-system-x86 qemu-user qemu-user-static qemu-user-binfmt qemu-utils 
qemu-guest-agent qemu-kvm qemu-system-aarch64
Architecture: source
Version: 1:2.4+dfsg-5ubuntu1
Distribution: xenial
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Changed-By: Matthias Klose <d...@ubuntu.com>
Description:
 qemu       - fast processor emulator
 qemu-block-extra - extra block backend modules for qemu-system and qemu-utils
 qemu-guest-agent - Guest-side qemu-system agent
 qemu-kvm   - QEMU Full virtualization
 qemu-system - QEMU full system emulation binaries
 qemu-system-aarch64 - QEMU full system emulation binaries (aarch64)
 qemu-system-arm - QEMU full system emulation binaries (arm)
 qemu-system-common - QEMU full system emulation binaries (common files)
 qemu-system-mips - QEMU full system emulation binaries (mips)
 qemu-system-misc - QEMU full system emulation binaries (miscelaneous)
 qemu-system-ppc - QEMU full system emulation binaries (ppc)
 qemu-system-sparc - QEMU full system emulation binaries (sparc)
 qemu-system-x86 - QEMU full system emulation binaries (x86)
 qemu-user  - QEMU user mode emulation binaries
 qemu-user-binfmt - QEMU user mode binfmt registration for qemu-user
 qemu-user-static - QEMU user mode emulation binaries (static version)
 qemu-utils - QEMU utilities
Closes: 802633 805410
Launchpad-Bugs-Fixed: 1495895
Changes:
 qemu (1:2.4+dfsg-5ubuntu1) xenial; urgency=medium
 .
   * Merge with Debian; remaining changes:
     - Update the ubuntu machine types patch to reflect upstream churn
     - debian/rules: do not drop the init scripts loading kvm modules
       (still needed in precise in cloud archive)
     - qemu-system-common.postinst:
       * remove acl placed by udev, and add udevadm trigger.
       * reload kvm_intel if needed to set nested=1
     - qemu-system-common.preinst: add kvm group if needed
     - add qemu-kvm upstart job and defaults file (rules,
       qemu-system-x86.qemu-kvm.default, qemu-system-x86.qemu-kvm.upstart)
     - rules,qemu-system-x86.modprobe: support use under older udevs which
       do not auto-load the kvm kernel module.  Enable nesting by default
       on intel.
     - d/p/ubuntu/expose-vmx_qemu64cpu.patch: enable nested kvm by default
       in qemu64 cpu type.
     - d/p/ubuntu/define-trusty-machine-type.patch: define a default trusty
       machine type to ease future live vm migration.
     - apport hook for qemu source package: d/source_qemu-kvm.py,
       d/qemu-system-common.install
     - Make qemu-system-common and qemu-utils depend on qemu-block-extra
       to fix errors with missing block backends. (LP: #1495895)
     - control-in: build with libseccomp an all architectures
     - Add vGICv3 support
 .
 qemu (1:2.4+dfsg-5) unstable; urgency=medium
 .
   * trace-remove-malloc-tracing.patch from upstream.
     (Closes: #802633)
   * stop building libcacard, as it is now in its own separate
     source package and has been removed from upstream qemu in 2.5.
     Here we just stop producing libcacard binaries, but still use
     embedded libcacard source to link with it statically.  In 2.5
     we will switch to external libcacard. (Closes: #805410)
Checksums-Sha1:
 0f844ca077ab57326493aa6907a49748a2cd5c11 6136 qemu_2.4+dfsg-5ubuntu1.dsc
 170f3b409586161ef08f16796c48d0b2a403973b 96864 
qemu_2.4+dfsg-5ubuntu1.debian.tar.xz
Checksums-Sha256:
 ec3162899544e6655247de42a515a2ce1e9b4e88f36c2403ef59c2fed3ba9711 6136 
qemu_2.4+dfsg-5ubuntu1.dsc
 6b11dcd9d374bb5ac5e074ee8ab935ec0a498c9a5db5c2f5d4400b8d7edbcef2 96864 
qemu_2.4+dfsg-5ubuntu1.debian.tar.xz
Files:
 5417ec3b302eca77da3aedc35e78502f 6136 otherosfs optional 
qemu_2.4+dfsg-5ubuntu1.dsc
 6c1912a18f7e3549f0732fe98bae8d6b 96864 otherosfs optional 
qemu_2.4+dfsg-5ubuntu1.debian.tar.xz
Original-Maintainer: Debian QEMU Team <pkg-qemu-de...@lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJWX10/AAoJEL1+qmB3j6b1T9wP/jrB4Glt3UUuM6fRbbSZ0S9G
w365R3ndxfJB2LBAzb5RQAGMM5xvjtpxPEVzYMWVV1GH+7H+/9kVOoA2S/gSPa+q
b2QCYWGxVF5FZFPmya9j6Q0QrptwenIIhnCrLwzcn2J5GwUYLFyoBAV3WuD7SjMV
irUii6exxAch9gwXJA/75n2KcO1qDEsNbSCuy2BRM29TW9LObNfhVCSJ7DWd6JXj
/Y9IaOLQ7t5bWrsVM0vbrehxdxC8cOkTrHIgKEwDOWBaNgWwOw0GE7C94fxX0Bvl
JoY/Oa+/BxzG0ETlXk7zPtFyh8TobPot28C2T2MSNsMG8GwmgJzLt24HO6qmFhH/
lc4ZcK+izkJMb6IxYlTitNWTiV3e5Ne+RhZUVQ8JcFcKW7slpPabs4Ufv1UEdqYz
Lz3y2Uob3sxF887DjFEb4X4pVO1+jkej3IP0ojuNVuQGwF81BvtRcNYETFg3ijb9
LV5KBoetZSFpoXzyGachPOhAZeSbrDUdTRz8oCDci489tgoD8pw2VMGoZ2hIDCqH
4X4nJRU/IoJfXq+VeKaeuWK8vYNf/OpYWsBfwHGlvNe5ZXZBn0xe20wyF2ARX2V0
RXUk1p75TTtDQTNrCc/g0rbnicv8BIiUN8KVgE1WOdVi5IOcM9NkjavbSstQCDuM
nIzaZ2p7gYjNQcNf/zML
=PBrL
-----END PGP SIGNATURE-----
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to