qemu (1:2.5+dfsg-1ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - debian/rules: do not drop the init scripts loading kvm modules
      (still needed in precise in cloud archive)
    - qemu-system-common.postinst:
      * remove acl placed by udev, and add udevadm trigger.
      * reload kvm_intel if needed to set nested=1
    - qemu-system-common.preinst: add kvm group if needed
    - add qemu-kvm upstart job and defaults file (rules,
      qemu-system-x86.qemu-kvm.default, qemu-system-x86.qemu-kvm.upstart)
    - rules,qemu-system-x86.modprobe: support use under older udevs which
      do not auto-load the kvm kernel module.  Enable nesting by default
      on intel.
    - d/p/ubuntu/expose-vmx_qemu64cpu.patch: enable nested kvm by default
      in qemu64 cpu type.
    - d/p/ubuntu/define-ubuntu-machine-types.patch: define distro machine
      types to ease future live vm migration.
    - apport hook for qemu source package: d/source_qemu-kvm.py,
      d/qemu-system-common.install
    - Make qemu-system-common and qemu-utils depend on qemu-block-extra
      to fix errors with missing block backends. (LP: #1495895)
    - Enable pie by default, on ubuntu/s390x.
  * Drop vGICv3 support patches - all is now upstream
  * debian/qemu-kvm-init: handle KVM_HUGEPAGES being unset (LP: #1531191)

qemu (1:2.5+dfsg-1) unstable; urgency=medium

  * new upstream release
    (Closes: #801158)
    Closes: #806373 CVE-2015-8345
    Closes: #806742 CVE-2015-7504
    Closes: #806741 CVE-2015-7512
    Closes: #808131 CVE-2015-7549
    Closes: #808130 CVE-2015-8504
  * adopt for the new upstream:
   - removed patches which are upstream now
   - build-depend on libcacard-dev and stop requiring libtool
   - removed libcacard refs from debian/qemu-system-common.docs
   - moved qmp docs out of subdir following upstream
   - removed pc-bios/vgabios-virtio.bin
  * enable new linux-user target: tilegx
  * install qemu-ga manpage
  * install ivshmem-server and ivshmem-client to qemu-utils
  * stop using cylinders/heads/sectors for sfdisk
    in qemu-make-debian-root (Closes: #785470)
  * modify qemu-make-debian-root to use some current tools
    (this simplifies things, removes usage of uudecode)
    (usefulness of this utility is questionable anyway)

Date: Tue, 05 Jan 2016 15:42:50 -0800
Changed-By: Serge Hallyn <serge.hal...@ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/qemu/1:2.5+dfsg-1ubuntu1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 05 Jan 2016 15:42:50 -0800
Source: qemu
Binary: qemu qemu-system qemu-block-extra qemu-system-common qemu-system-misc 
qemu-system-arm qemu-system-mips qemu-system-ppc qemu-system-sparc 
qemu-system-x86 qemu-user qemu-user-static qemu-user-binfmt qemu-utils 
qemu-guest-agent qemu-kvm qemu-system-aarch64
Architecture: source
Version: 1:2.5+dfsg-1ubuntu1
Distribution: xenial
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Changed-By: Serge Hallyn <serge.hal...@ubuntu.com>
Description:
 qemu       - fast processor emulator
 qemu-block-extra - extra block backend modules for qemu-system and qemu-utils
 qemu-guest-agent - Guest-side qemu-system agent
 qemu-kvm   - QEMU Full virtualization
 qemu-system - QEMU full system emulation binaries
 qemu-system-aarch64 - QEMU full system emulation binaries (aarch64)
 qemu-system-arm - QEMU full system emulation binaries (arm)
 qemu-system-common - QEMU full system emulation binaries (common files)
 qemu-system-mips - QEMU full system emulation binaries (mips)
 qemu-system-misc - QEMU full system emulation binaries (miscelaneous)
 qemu-system-ppc - QEMU full system emulation binaries (ppc)
 qemu-system-sparc - QEMU full system emulation binaries (sparc)
 qemu-system-x86 - QEMU full system emulation binaries (x86)
 qemu-user  - QEMU user mode emulation binaries
 qemu-user-binfmt - QEMU user mode binfmt registration for qemu-user
 qemu-user-static - QEMU user mode emulation binaries (static version)
 qemu-utils - QEMU utilities
Closes: 785470 801158 806373 806741 806742 808130 808131
Launchpad-Bugs-Fixed: 1495895 1531191
Changes:
 qemu (1:2.5+dfsg-1ubuntu1) xenial; urgency=medium
 .
   * Merge with Debian; remaining changes:
     - debian/rules: do not drop the init scripts loading kvm modules
       (still needed in precise in cloud archive)
     - qemu-system-common.postinst:
       * remove acl placed by udev, and add udevadm trigger.
       * reload kvm_intel if needed to set nested=1
     - qemu-system-common.preinst: add kvm group if needed
     - add qemu-kvm upstart job and defaults file (rules,
       qemu-system-x86.qemu-kvm.default, qemu-system-x86.qemu-kvm.upstart)
     - rules,qemu-system-x86.modprobe: support use under older udevs which
       do not auto-load the kvm kernel module.  Enable nesting by default
       on intel.
     - d/p/ubuntu/expose-vmx_qemu64cpu.patch: enable nested kvm by default
       in qemu64 cpu type.
     - d/p/ubuntu/define-ubuntu-machine-types.patch: define distro machine
       types to ease future live vm migration.
     - apport hook for qemu source package: d/source_qemu-kvm.py,
       d/qemu-system-common.install
     - Make qemu-system-common and qemu-utils depend on qemu-block-extra
       to fix errors with missing block backends. (LP: #1495895)
     - Enable pie by default, on ubuntu/s390x.
   * Drop vGICv3 support patches - all is now upstream
   * debian/qemu-kvm-init: handle KVM_HUGEPAGES being unset (LP: #1531191)
 .
 qemu (1:2.5+dfsg-1) unstable; urgency=medium
 .
   * new upstream release
     (Closes: #801158)
     Closes: #806373 CVE-2015-8345
     Closes: #806742 CVE-2015-7504
     Closes: #806741 CVE-2015-7512
     Closes: #808131 CVE-2015-7549
     Closes: #808130 CVE-2015-8504
   * adopt for the new upstream:
    - removed patches which are upstream now
    - build-depend on libcacard-dev and stop requiring libtool
    - removed libcacard refs from debian/qemu-system-common.docs
    - moved qmp docs out of subdir following upstream
    - removed pc-bios/vgabios-virtio.bin
   * enable new linux-user target: tilegx
   * install qemu-ga manpage
   * install ivshmem-server and ivshmem-client to qemu-utils
   * stop using cylinders/heads/sectors for sfdisk
     in qemu-make-debian-root (Closes: #785470)
   * modify qemu-make-debian-root to use some current tools
     (this simplifies things, removes usage of uudecode)
     (usefulness of this utility is questionable anyway)
Checksums-Sha1:
 bbdd919f175c50e94773cef509fb440f61d48d3c 5780 qemu_2.5+dfsg-1ubuntu1.dsc
 75dbdc7d2faaf988276ee45fb696faa0b9ef5bcb 5917224 qemu_2.5+dfsg.orig.tar.xz
 e7b0eaade2104a34c90ed167c19d964064981a3d 74020 
qemu_2.5+dfsg-1ubuntu1.debian.tar.xz
Checksums-Sha256:
 c063fe4ca3725a21b98f3798209baa9e05c9313fa806285fb0d1aa8f138c3e5b 5780 
qemu_2.5+dfsg-1ubuntu1.dsc
 7507dc37281ac7a42e13fff062a88e8742734d42fad2b6c2aeb6cc96060b120a 5917224 
qemu_2.5+dfsg.orig.tar.xz
 d0a9c5a985ec9275c6e2127a4e3d3d2befe03b2478d74923cf90f032ae1ade81 74020 
qemu_2.5+dfsg-1ubuntu1.debian.tar.xz
Files:
 ccdd04ecdaea3608bdd4b12120c1912b 5780 otherosfs optional 
qemu_2.5+dfsg-1ubuntu1.dsc
 83a1b1bc152dd9b46a3bd992930a8db7 5917224 otherosfs optional 
qemu_2.5+dfsg.orig.tar.xz
 e62fe113ca0e69b985d6cb62e4a3c621 74020 otherosfs optional 
qemu_2.5+dfsg-1ubuntu1.debian.tar.xz
Original-Maintainer: Debian QEMU Team <pkg-qemu-de...@lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBCgAGBQJWjFlnAAoJEOn+6gaoXj+deYMH/iqe7MY7WXbM+4Zm2DQ0ORxm
aT7/YIM/eA4lz2iWS8zyJrOh7n2jAz03MvFDjvVu+LDBfYnxpy3JTEByJ+jRayfu
ka+YkyfiABubTsFQ3YnWa1eaoimVp4R1EthXyK6tiiO5mLpAJTpGozAw8p+Y0J/+
IcO/9iq3horanFbBCF1tPXRnBSAVQ+S67Nod2W/UR943UrQisG8dzdVY3PMtl7m4
MNpPTHARVwfvmX0Xz6iYfs1KX8vgchM5jQox4meFPNXkjY74kpkfuUrFQ4EdueqE
D7tFLQL6/tGXwTdXWYT9ChWePGKg/RfEeBZR8+8QnHbuziulk/LMkr749TKcbtA=
=CpeF
-----END PGP SIGNATURE-----
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to