mumble (1.2.12-1ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Fix include path for the speechd headers.

mumble (1.2.12-1) unstable; urgency=medium

  * New bugfix release from 2015-12-20
  * debian/patches:
    - Update 35-add-dpkg-buildflags.diff to remove version # context to
      avoid having to update the patch with every release
    - Rename 40-change-build-timestamp.diff -> 40-make-build-reproducible.diff
      Update to remove the timestamps as the upstream commit does, and remove
      version # context line to avoid having to update the patch with every
      release

mumble (1.2.11-1) unstable; urgency=medium

  * New upstream security/bugfix release from 2015-12-06
  * debian/copyright:
    - Convert to machine readable copyright-1.0 format
  * debian/patches:
    - Remove 02-reject-with-ip-in-log.diff; integrated upstream
    - Remove 15-add-mumble.desktop-keywords.diff; integrated upstream
    - Update 35-add-dpkg-buildflags.diff for version number
    - Update 40-change-build-timestamp.diff for version number

mumble (1.2.10-3) unstable; urgency=high

  * debian/patches:
      - Add 43-initialize-SSL.diff to fix SSL breakage on startup
        Closes: #804363
        Thanks very much to Colomban Wendling <lists....@herbesfolles.org>
        for reporting the bug and offering a fix.

mumble (1.2.10-2) unstable; urgency=high

  * debian/mumble.lintian-overrides:
      - Add override for useless ldconfig call in postinst added by debhelper
  * debian/patches:
      - Add 38-fix-spelling-error.diff .. "nonexistant" to "nonexistent"
      - Add 40-change-build-timestamp.diff .. use debian changelog date/time
        instead of current date/time for the build.  (Needed for
        Reproducible Builds)
  * debian/rules:
      - Comment out DH_VERBOSE=1
      - Add BUILD_DATE shell variable for use with 40-change-build-timestamp
        patch (used in src/Version.h)
      - Use $(CURDIR) instead of '.' in override_dh_installinit section
      - Re-order dh_installinit call in override_dh_installinit to be after
        copying init script to $(CURDIR)/debian  Closes: #802390
        Thanks to  Daniel Gnoutcheff <gnout...@softwarefreedom.org> for
        reporting the bug (missing init script).

mumble (1.2.10-1) unstable; urgency=medium

  * New stable maintenance release from 2015-07-15  Closes: #797788
  * debian/compat:
      - Update from 7 to 9
        Update to debhelper 9 changes the filenames contained in mumble-dbg
        because dh_strip uses build-id in /usr/lib/debug (see #642158)
  * debian/control:
      - Update debhelper build dependency from 7.0.8 to 9
      - Standards-Version updated to 3.9.6 (no changes needed)
      - Remove hardening-wrapper build dependency
        (now using dpkg-buildflags instead)
  * debian/copyright:
      - Tweak from "GPU Public License" to "GNU General Public License" to
        appease lintian
  * debian/mumble.menu:
      - Remove menu file to conform with [CTTE #741573]
  * debian/patches:
      - Update 19-move-xlib-initializtion-earlier.diff for line offset fuzz
      - Remove 21-fix-compile-with-gcc-4.9.diff as it's been incorporated
      - Add 27-prevent-flooding-.xsession-errors.diff to stop .xsession
        being flooded with errors after waking from hibernation.
        Closes: #779836
        Thanks to Fran├žois Gannaz <francois.gan...@free.fr> for reporting the
        bug and pointing to the bug report filed upstream that had a patch.
      - Add 30-Remove-flawed-MX-host-existence-check.diff to stop checking
        certificate email addresses via checking for a DNS 'A' record
        Closes: #787384
        Thanks to  Brian M. Carlson <sand...@crustytoothpaste.net> for
        reporting the bug and pointing to upstream issue #1178
      - Add 35-add-dpkg-buildflags.diff to add hardening flags to compiler.pri
        and overlay_gl.pro
  * debian/po/pt_BR.po: Add Brazilian Portuguese support (Closes: #799422)
        Thanks to Adriano Rafael Gomes <adrian...@arg.eti.br> for the
        translation
  * debian/rules:
      - Update to switch from individual debhelper calls to dh with overrides.
      - Remove unused DEB_BUILD hardening-wrapper environment variables
  * debian/upstream/signing-key.asc
      - Update for new Mumble upstream signing key from 2015-01-01
        http://mumble.info/gpg/mumble-auto-build-2015.asc
  * debian/watch:
      - Update to watch only the "stable" upstream releases

Date: Fri, 08 Jan 2016 17:23:37 +0100
Changed-By: Matthias Klose <d...@ubuntu.com>
Maintainer: Christopher Knadle <chris.kna...@coredump.us>
https://launchpad.net/ubuntu/+source/mumble/1.2.12-1ubuntu1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Fri, 08 Jan 2016 17:23:37 +0100
Source: mumble
Binary: mumble mumble-server mumble-dbg
Architecture: source
Version: 1.2.12-1ubuntu1
Distribution: xenial
Urgency: high
Maintainer: Christopher Knadle <chris.kna...@coredump.us>
Changed-By: Matthias Klose <d...@ubuntu.com>
Description:
 mumble     - Low latency encrypted VoIP client
 mumble-dbg - Low latency encrypted VoIP client (debugging symbols)
 mumble-server - Low latency encrypted VoIP server
Closes: 779836 787384 797788 799422 802390 804363
Changes:
 mumble (1.2.12-1ubuntu1) xenial; urgency=medium
 .
   * Merge with Debian; remaining changes:
     - Fix include path for the speechd headers.
 .
 mumble (1.2.12-1) unstable; urgency=medium
 .
   * New bugfix release from 2015-12-20
   * debian/patches:
     - Update 35-add-dpkg-buildflags.diff to remove version # context to
       avoid having to update the patch with every release
     - Rename 40-change-build-timestamp.diff -> 40-make-build-reproducible.diff
       Update to remove the timestamps as the upstream commit does, and remove
       version # context line to avoid having to update the patch with every
       release
 .
 mumble (1.2.11-1) unstable; urgency=medium
 .
   * New upstream security/bugfix release from 2015-12-06
   * debian/copyright:
     - Convert to machine readable copyright-1.0 format
   * debian/patches:
     - Remove 02-reject-with-ip-in-log.diff; integrated upstream
     - Remove 15-add-mumble.desktop-keywords.diff; integrated upstream
     - Update 35-add-dpkg-buildflags.diff for version number
     - Update 40-change-build-timestamp.diff for version number
 .
 mumble (1.2.10-3) unstable; urgency=high
 .
   * debian/patches:
       - Add 43-initialize-SSL.diff to fix SSL breakage on startup
         Closes: #804363
         Thanks very much to Colomban Wendling <lists....@herbesfolles.org>
         for reporting the bug and offering a fix.
 .
 mumble (1.2.10-2) unstable; urgency=high
 .
   * debian/mumble.lintian-overrides:
       - Add override for useless ldconfig call in postinst added by debhelper
   * debian/patches:
       - Add 38-fix-spelling-error.diff .. "nonexistant" to "nonexistent"
       - Add 40-change-build-timestamp.diff .. use debian changelog date/time
         instead of current date/time for the build.  (Needed for
         Reproducible Builds)
   * debian/rules:
       - Comment out DH_VERBOSE=1
       - Add BUILD_DATE shell variable for use with 40-change-build-timestamp
         patch (used in src/Version.h)
       - Use $(CURDIR) instead of '.' in override_dh_installinit section
       - Re-order dh_installinit call in override_dh_installinit to be after
         copying init script to $(CURDIR)/debian  Closes: #802390
         Thanks to  Daniel Gnoutcheff <gnout...@softwarefreedom.org> for
         reporting the bug (missing init script).
 .
 mumble (1.2.10-1) unstable; urgency=medium
 .
   * New stable maintenance release from 2015-07-15  Closes: #797788
   * debian/compat:
       - Update from 7 to 9
         Update to debhelper 9 changes the filenames contained in mumble-dbg
         because dh_strip uses build-id in /usr/lib/debug (see #642158)
   * debian/control:
       - Update debhelper build dependency from 7.0.8 to 9
       - Standards-Version updated to 3.9.6 (no changes needed)
       - Remove hardening-wrapper build dependency
         (now using dpkg-buildflags instead)
   * debian/copyright:
       - Tweak from "GPU Public License" to "GNU General Public License" to
         appease lintian
   * debian/mumble.menu:
       - Remove menu file to conform with [CTTE #741573]
   * debian/patches:
       - Update 19-move-xlib-initializtion-earlier.diff for line offset fuzz
       - Remove 21-fix-compile-with-gcc-4.9.diff as it's been incorporated
       - Add 27-prevent-flooding-.xsession-errors.diff to stop .xsession
         being flooded with errors after waking from hibernation.
         Closes: #779836
         Thanks to Fran├žois Gannaz <francois.gan...@free.fr> for reporting the
         bug and pointing to the bug report filed upstream that had a patch.
       - Add 30-Remove-flawed-MX-host-existence-check.diff to stop checking
         certificate email addresses via checking for a DNS 'A' record
         Closes: #787384
         Thanks to  Brian M. Carlson <sand...@crustytoothpaste.net> for
         reporting the bug and pointing to upstream issue #1178
       - Add 35-add-dpkg-buildflags.diff to add hardening flags to compiler.pri
         and overlay_gl.pro
   * debian/po/pt_BR.po: Add Brazilian Portuguese support (Closes: #799422)
         Thanks to Adriano Rafael Gomes <adrian...@arg.eti.br> for the
         translation
   * debian/rules:
       - Update to switch from individual debhelper calls to dh with overrides.
       - Remove unused DEB_BUILD hardening-wrapper environment variables
   * debian/upstream/signing-key.asc
       - Update for new Mumble upstream signing key from 2015-01-01
         http://mumble.info/gpg/mumble-auto-build-2015.asc
   * debian/watch:
       - Update to watch only the "stable" upstream releases
Checksums-Sha1:
 b133fffcdb219132a5f227a4ee0eb61dc9edc6bd 2247 mumble_1.2.12-1ubuntu1.dsc
 0ec616865410d19b8b23d5d83e66610650b88a39 38736 
mumble_1.2.12-1ubuntu1.debian.tar.xz
Checksums-Sha256:
 cd971ba0cc1846aeab30c9bdf2e3c2c38ca31812c32d39f997c03ecca2321e22 2247 
mumble_1.2.12-1ubuntu1.dsc
 cf907425dd3e5cc5cc6f7c66bd9a382cfd145ef3cb8b8a2e26d0de8e8fd84f8d 38736 
mumble_1.2.12-1ubuntu1.debian.tar.xz
Files:
 8b68c1387df10f189631acee45ce5665 2247 sound optional mumble_1.2.12-1ubuntu1.dsc
 82e91ac8ce24ae39188c1367190e687f 38736 sound optional 
mumble_1.2.12-1ubuntu1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJWj+PGAAoJEL1+qmB3j6b1cS4P/3zj9aco40fMuuqKkWYVJp6T
NZcL84HyzfgFe5Ef9mF+wQZ1yhZ8cAuGmZhVgaRETq8uMsP17b8bTNSiOcVyWHJC
T5l2bJDINy4Zg/Qu1SUNcAlAfEUTcygjYeUKHx/Zd4Xh87RVZng1dtYxnL9RBu1o
lfIXUe7gByeZmUGuuiqZelbqvuiX9G+Sbjq1U+mk86g8CcVKH+jU88Wc2zJhE65e
r1MRG0zA5Jtk8Ledl91tiY51aZAuSR+BPPMdi75jg5E1FonbdKNJu4N/iERj9nXb
xZC9GhosHPk5RPJby07F3NvQAR4sJTsRumTSFVtYvvAL9MCd6BBaYmXuuQ1m/MSw
qtFEgf6Jypmm/LvIQNT8FDyVNbbpDOHGfUJCpHn21TEOpckOSfmL2cn+Hu6HeJPv
k9DXRhfGON8FpOfdTZgxPUAB/rHLnYl8ETir+qdJnMoOQ6zJVXE0EbOpQWoe73or
PWjhoUH2JeNIKSgydbJFttPzF/xxqBG6PARCtWEiTOnDVuAauwwRNRj6bf4AHIGm
xFVUqhMMcDzBBbHatfxBGxV+fV0plbbEf+HhaSbpek9M0Bh5X0pG2swEY90MXE56
PLzm8pXEQjVDAkVGNcnXSaGYl5YIfCyt86MnfdTVjAHhYpWluF92W+42clqScBdq
uxoLlxMmoid4BnMAMBGk
=mktL
-----END PGP SIGNATURE-----
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to