libwnck (1:2.30.7-5ubuntu1) xenial; urgency=medium

  * Merge with Debian, remaining changes from Ubuntu:
    - debian/patches/02_moveresize_static_gravity.patch
    - debian/patches/03_window_action_menu_dispose_events.patch

libwnck (2.30.7-5) unstable; urgency=medium

  * debian/control:
    + Add D (libwnck-dev): libxres-dev. (Closes: #814588).

libwnck (2.30.7-4) unstable; urgency=medium

  * debian/control:
    + Add D (libwnck-dev): gir1.2-wnck-1.0 (same bin:version of the package).
    + Drop Multi-Arch: field for libwnck-dev.

libwnck (2.30.7-3) unstable; urgency=low

  [ Josselin Mouette ]
  * 01_tasklist_orientation.patch: define
    WNCK_I_KNOW_THIS_IS_NOT_UPSTREAM in Makefile.am.
    Really closes: #558581.
  * Remove the CFLAGS.

  [ Mike Gabriel ]
  * debian/watch:
    + Don't report 3.x upstream versions of libwnck.
  * debian/rules:
    + Add --fail-missing dh_install argument.
    + Enable parallel builds.
    + Drop GNOME-specific CDBS includes.
    + Add get-orig-source rule.
    + Turn pkg into CDBS class "autotools".
    + Remove unwanted (cruft) files after build.
  * debian/control:
    + Move package from pkg-gnome to pkg-mate maintenance. As discussed with
      Dmitry Shachnev on #debian-gnome IRC on 8th Feb 2016.
    + Drop GNOME's control.in file, Move control.in to control.
    + Update maintainer change in Vcs-*: fields.
    + Add Homepage: field, pointing to 2.30.x API documentation.
    + Bump Standards: version. No changes needed.
    + Bump DH compatibility level to DH version 9.
    + Drop B-D: gnome-pkg-tools.
    + Add dbg bin:package for libwnck22.
    + Turn libwnck into multi-arch package.
    + Hint that this package provides WNCK for GTK-2 based applications.
    + Special sections for the debug and the introspection bin:package.
    + Fix Breaks:/Conflicts:/Replaces logic regarding libwnck-1. (Closes:
      #444428).
  * libwnck22.symbols:
    + Provide .symbols file for libwnck.
  * debian/libwnck22.shlibs:
    + Drop outdated .shlibs file.
  * debian/gir1.2-wnck-1.0.install:
    + Provide dh_install file list for new bin:package gir1.2-wnck-1.0.
      Drop debian/gir1.0-wnck-1.0.install.
  * debian/libwnck22.install:
    + Use architecture-specific library path.
  * debian/libwnck-dev.install:
    + Use architecture-specific paths.
  * documentation:
    + Move all documentation into new bin:package libwnck-doc.
  * debian/copyright:
    + Provide auto-generated copyright.in file (thanks to CDBS).
    + Turn into DEP-5 compliant format.
  * debian/patches:
    + Provide patch header for 99_ltmain_as-needed.patch.
  * lintian:
    + Ignore wrong shared library bin:package name for now (not matching .so
      file name).

  [ Martin Wimpress ]
  * debian/control:
    + Add bin:package gir1.2-wnck-1.0. Required for upcoming src:package
      mate-dock-applet.

libwnck (2.30.7-2) unstable; urgency=medium

  * Team upload.

  [ Andreas Henriksson ]
  * debian/control.in: Add Vcs-* URLs

  [ Andreas Barth ]
  * debian/rules: include autoreconf.mk and add CFLAGS to avoid
    build failure on missing prototypes. (Closes: #558581)

  [ Andreas Henriksson ]
  * Add dh-autoreconf build-dependency as required by previous change.

libwnck (2.30.7-1) unstable; urgency=low

  * New upstream release.

  [ Michael Terry ]
  * debian/libwnck-dev.install:
    - Don't install wnckprop, it conflicts with libwnck-3-dev

  [ Michael Biebl ]
  * Remove debian/patches/10_pager_multirow.patch, merged upstream.
  * debian/watch:
    - Update to version 3.
    - Track .xz tarballs.
  * Bump debhelper compatibility to 8.
    - Update Build-Depends on debhelper.
    - Strip debian/tmp/ from .install files.
  * debian/control.in:
    - Bump Standards-Version to 3.9.2. No further changes.
    - Drop obsolete versioned Build-Depends on dpkg-dev.

Date: Wed, 17 Feb 2016 11:57:08 +0000
Changed-By: Martin Wimpress <c...@flexion.org>
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Signed-By: Iain Lane <i...@orangesquash.org.uk>
https://launchpad.net/ubuntu/+source/libwnck/1:2.30.7-5ubuntu1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 17 Feb 2016 11:57:08 +0000
Source: libwnck
Binary: libwnck22 libwnck-dev libwnck-common libwnck-dbg libwnck-doc 
gir1.2-wnck-1.0
Architecture: source
Version: 1:2.30.7-5ubuntu1
Distribution: xenial
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Changed-By: Martin Wimpress <c...@flexion.org>
Description:
 gir1.2-wnck-1.0 - GObject introspection data for the WNCK library
 libwnck-common - Window Navigator Construction Kit - common files
 libwnck-dbg - Window Navigator Construction Kit - debugging symbols
 libwnck-dev - Window Navigator Construction Kit - development files
 libwnck-doc - Window Navigator Construction Kit - documentation files
 libwnck22  - Window Navigator Construction Kit - runtime files
Closes: 444428 558581 814588
Changes:
 libwnck (1:2.30.7-5ubuntu1) xenial; urgency=medium
 .
   * Merge with Debian, remaining changes from Ubuntu:
     - debian/patches/02_moveresize_static_gravity.patch
     - debian/patches/03_window_action_menu_dispose_events.patch
 .
 libwnck (2.30.7-5) unstable; urgency=medium
 .
   * debian/control:
     + Add D (libwnck-dev): libxres-dev. (Closes: #814588).
 .
 libwnck (2.30.7-4) unstable; urgency=medium
 .
   * debian/control:
     + Add D (libwnck-dev): gir1.2-wnck-1.0 (same bin:version of the package).
     + Drop Multi-Arch: field for libwnck-dev.
 .
 libwnck (2.30.7-3) unstable; urgency=low
 .
   [ Josselin Mouette ]
   * 01_tasklist_orientation.patch: define
     WNCK_I_KNOW_THIS_IS_NOT_UPSTREAM in Makefile.am.
     Really closes: #558581.
   * Remove the CFLAGS.
 .
   [ Mike Gabriel ]
   * debian/watch:
     + Don't report 3.x upstream versions of libwnck.
   * debian/rules:
     + Add --fail-missing dh_install argument.
     + Enable parallel builds.
     + Drop GNOME-specific CDBS includes.
     + Add get-orig-source rule.
     + Turn pkg into CDBS class "autotools".
     + Remove unwanted (cruft) files after build.
   * debian/control:
     + Move package from pkg-gnome to pkg-mate maintenance. As discussed with
       Dmitry Shachnev on #debian-gnome IRC on 8th Feb 2016.
     + Drop GNOME's control.in file, Move control.in to control.
     + Update maintainer change in Vcs-*: fields.
     + Add Homepage: field, pointing to 2.30.x API documentation.
     + Bump Standards: version. No changes needed.
     + Bump DH compatibility level to DH version 9.
     + Drop B-D: gnome-pkg-tools.
     + Add dbg bin:package for libwnck22.
     + Turn libwnck into multi-arch package.
     + Hint that this package provides WNCK for GTK-2 based applications.
     + Special sections for the debug and the introspection bin:package.
     + Fix Breaks:/Conflicts:/Replaces logic regarding libwnck-1. (Closes:
       #444428).
   * libwnck22.symbols:
     + Provide .symbols file for libwnck.
   * debian/libwnck22.shlibs:
     + Drop outdated .shlibs file.
   * debian/gir1.2-wnck-1.0.install:
     + Provide dh_install file list for new bin:package gir1.2-wnck-1.0.
       Drop debian/gir1.0-wnck-1.0.install.
   * debian/libwnck22.install:
     + Use architecture-specific library path.
   * debian/libwnck-dev.install:
     + Use architecture-specific paths.
   * documentation:
     + Move all documentation into new bin:package libwnck-doc.
   * debian/copyright:
     + Provide auto-generated copyright.in file (thanks to CDBS).
     + Turn into DEP-5 compliant format.
   * debian/patches:
     + Provide patch header for 99_ltmain_as-needed.patch.
   * lintian:
     + Ignore wrong shared library bin:package name for now (not matching .so
       file name).
 .
   [ Martin Wimpress ]
   * debian/control:
     + Add bin:package gir1.2-wnck-1.0. Required for upcoming src:package
       mate-dock-applet.
 .
 libwnck (2.30.7-2) unstable; urgency=medium
 .
   * Team upload.
 .
   [ Andreas Henriksson ]
   * debian/control.in: Add Vcs-* URLs
 .
   [ Andreas Barth ]
   * debian/rules: include autoreconf.mk and add CFLAGS to avoid
     build failure on missing prototypes. (Closes: #558581)
 .
   [ Andreas Henriksson ]
   * Add dh-autoreconf build-dependency as required by previous change.
 .
 libwnck (2.30.7-1) unstable; urgency=low
 .
   * New upstream release.
 .
   [ Michael Terry ]
   * debian/libwnck-dev.install:
     - Don't install wnckprop, it conflicts with libwnck-3-dev
 .
   [ Michael Biebl ]
   * Remove debian/patches/10_pager_multirow.patch, merged upstream.
   * debian/watch:
     - Update to version 3.
     - Track .xz tarballs.
   * Bump debhelper compatibility to 8.
     - Update Build-Depends on debhelper.
     - Strip debian/tmp/ from .install files.
   * debian/control.in:
     - Bump Standards-Version to 3.9.2. No further changes.
     - Drop obsolete versioned Build-Depends on dpkg-dev.
Checksums-Sha1:
 ef7b00c29b769bcae8242e38ed5205eb114b6af5 2682 libwnck_2.30.7-5ubuntu1.dsc
 06c80da21ded9d482aac92b6fa91f2a718ba28d6 20184 
libwnck_2.30.7-5ubuntu1.debian.tar.xz
Checksums-Sha256:
 24c997fe283702de2d28d5532186bee97f798715e46950972c0e3e6069ed5efa 2682 
libwnck_2.30.7-5ubuntu1.dsc
 13c62d4005d3e51ff3f9acdb7827a8aaf6c8e7bc3b74af3aa549ed15f608f39c 20184 
libwnck_2.30.7-5ubuntu1.debian.tar.xz
Files:
 5248f77d5aa13db84d037f754ef1b402 2682 libs optional libwnck_2.30.7-5ubuntu1.dsc
 dc5143912f76780aa5b52e0e1c89292b 20184 libs optional 
libwnck_2.30.7-5ubuntu1.debian.tar.xz
Original-Maintainer: Debian MATE Packaging Team 
<pkg-mate-t...@lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJWxGGvAAoJEONS1cUcUEHU0Y0QAKgdEIQK7rjjdLLyHItom9aU
SE/fz3UWnDNbw+OBPojx9bxBQFo/zCe6ylJ4a5LciWKsluHgyiSWTl/++MsUg6d6
zZCMSDUjlavvdaW1ZYsUJ8gFovEhlhbKgJaZC9gYrezZwnbn4c/w+CdmwLkilZKQ
kTFhn0Nxnaw2/D8g+sOe8Biu17qa8w6wpUkwp1f+GgsQ8KPcGQ8Xt4i2tiCOv65q
1dC6t/YTVhHl98vP3b5KZm2M9oFSqERZoDcpwKRt2XwzCCicsx85TI+YFJ5w6BTg
Vo1++clv3FmqKMbptoM2zAYkV7NEOniJztMyp8lsVcmhl/jdzVdcXeaQc10zPnrG
IBEEEFqgUmw0EpDJxi2v+1XEW80U6Av7gKLLcqRF8Kb17iixvWzJlVaT+N7JVlee
u0+sV4/Om2zRdwwEtRZWw/+NPyJ57yKlbLDSWCqyy3fTPPL+aSliFEL2kkqzCtQn
ZHt2oqhGLOaqPxQ6nmwKzaakfUUiDn9NOtdbV5jS9lgbO2CrNeopyYqHZTPP53tg
G3UwGRmosD88RYTQ4bDVnWym4wuG5XNcDrIocZowJS31QkoOYoqyjtQevomLSyB4
Kb2WsOap40pb++JmhTgjPYGHVfJmxWOP1+NalAbwOiJBNpF0267adbfHr8HCBaJc
GItRovh37MqsXHinAUWs
=iDIP
-----END PGP SIGNATURE-----
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to