webkit2gtk (2.10.8-1ubuntu1) xenial; urgency=low

  * Build with GeoClue 1, which is what we still use in Ubuntu.

webkit2gtk (2.10.8-1) unstable; urgency=high

  * New upstream release. This fixes CVE-2016-1726 (Closes: #802380).
  * Allow building the package with debhelper < 9.20151219. This won't
    produce any debug packages (since they are automatically generated
    now), but it can be useful for backports.
    + debian/control:
      - Revert build dependency on debhelper back to >= 9.
    + debian/rules:
      - Don't make dh_strip fail if it doesn't support --ddeb-migration.
  * debian/rules:
    + The list of architectures in which the debug packages are causing
      problems continues to grow, so let's try the opposite approach: we
      build by default using -g1 except in the cases where we know that
      -g works fine (amd64, ppc64, ppc64el).
    + Enable all hardening flags.
  * debian/patches/fix-ftbfs-m68k.patch:
    + Enclose the changes to the compile assertions inside an #ifdef block
      so they only apply to m68k.
  * debian/patches/fix-ftbfs-alpha.patch:
    + Fix FTBFS in alpha (Closes: #815124).
  * debian/patches/fix-ftbfs-sparc64.patch:
    + Add patch metadata.
  * debian/source/lintian-overrides:
    + Update overrides so the latest lintian doesn't give more
      source-is-missing false positives.
  * debian/control:
    + Bump Standards-Version to 3.9.7; no changes needed.
    + Use secure URIs for the Vcs-* fields.

Date: Tue, 15 Mar 2016 10:59:14 +0000
Changed-By: Iain Lane <i...@orangesquash.org.uk>
Maintainer: Debian WebKit Maintainers 
<pkg-webkit-maintain...@lists.alioth.debian.org>
https://launchpad.net/ubuntu/+source/webkit2gtk/2.10.8-1ubuntu1
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 15 Mar 2016 10:59:14 +0000
Source: webkit2gtk
Binary: libjavascriptcoregtk-4.0-18 libjavascriptcoregtk-4.0-dev 
libjavascriptcoregtk-4.0-bin gir1.2-javascriptcoregtk-4.0 libwebkit2gtk-4.0-37 
libwebkit2gtk-4.0-dev libwebkit2gtk-4.0-doc gir1.2-webkit2-4.0 
libwebkit2gtk-4.0-37-gtk2
Architecture: source
Version: 2.10.8-1ubuntu1
Distribution: xenial
Urgency: high
Maintainer: Debian WebKit Maintainers 
<pkg-webkit-maintain...@lists.alioth.debian.org>
Changed-By: Iain Lane <i...@orangesquash.org.uk>
Description:
 gir1.2-javascriptcoregtk-4.0 - JavaScript engine library from WebKitGTK+ - 
GObject introspection
 gir1.2-webkit2-4.0 - Web content engine library for GTK+ - GObject 
introspection data
 libjavascriptcoregtk-4.0-18 - JavaScript engine library from WebKitGTK+
 libjavascriptcoregtk-4.0-bin - JavaScript engine library from WebKitGTK+ - 
command-line interpre
 libjavascriptcoregtk-4.0-dev - JavaScript engine library from WebKitGTK+ - 
development files
 libwebkit2gtk-4.0-37 - Web content engine library for GTK+
 libwebkit2gtk-4.0-37-gtk2 - Web content engine library for GTK+ - GTK+2 plugin 
process
 libwebkit2gtk-4.0-dev - Web content engine library for GTK+ - development files
 libwebkit2gtk-4.0-doc - Web content engine library for GTK+ - documentation
Closes: 802380 815124
Changes:
 webkit2gtk (2.10.8-1ubuntu1) xenial; urgency=low
 .
   * Build with GeoClue 1, which is what we still use in Ubuntu.
 .
 webkit2gtk (2.10.8-1) unstable; urgency=high
 .
   * New upstream release. This fixes CVE-2016-1726 (Closes: #802380).
   * Allow building the package with debhelper < 9.20151219. This won't
     produce any debug packages (since they are automatically generated
     now), but it can be useful for backports.
     + debian/control:
       - Revert build dependency on debhelper back to >= 9.
     + debian/rules:
       - Don't make dh_strip fail if it doesn't support --ddeb-migration.
   * debian/rules:
     + The list of architectures in which the debug packages are causing
       problems continues to grow, so let's try the opposite approach: we
       build by default using -g1 except in the cases where we know that
       -g works fine (amd64, ppc64, ppc64el).
     + Enable all hardening flags.
   * debian/patches/fix-ftbfs-m68k.patch:
     + Enclose the changes to the compile assertions inside an #ifdef block
       so they only apply to m68k.
   * debian/patches/fix-ftbfs-alpha.patch:
     + Fix FTBFS in alpha (Closes: #815124).
   * debian/patches/fix-ftbfs-sparc64.patch:
     + Add patch metadata.
   * debian/source/lintian-overrides:
     + Update overrides so the latest lintian doesn't give more
       source-is-missing false positives.
   * debian/control:
     + Bump Standards-Version to 3.9.7; no changes needed.
     + Use secure URIs for the Vcs-* fields.
Checksums-Sha1:
 47caa04baecd89523745b8f9154e6e27af911b90 3585 webkit2gtk_2.10.8-1ubuntu1.dsc
 e27ec325e54d340f69d39ab26085de5a4104cf86 10994340 webkit2gtk_2.10.8.orig.tar.xz
 3ef704d745f8c5c9f7a6ddef10a816bba73bfafa 55100 
webkit2gtk_2.10.8-1ubuntu1.debian.tar.xz
Checksums-Sha256:
 9a9d252926fe1abecab6f5e36dc15696c015cb551de642502bbe6b3b42773eb8 3585 
webkit2gtk_2.10.8-1ubuntu1.dsc
 313682b23f03c457b28a7ef2d5bdb70a8174cca1d32e0a853fb36fa4dcf928a9 10994340 
webkit2gtk_2.10.8.orig.tar.xz
 4f2cf7248dbed7251d95e60b9a328f5bba16a13b7e062c0f02fe6c179491778c 55100 
webkit2gtk_2.10.8-1ubuntu1.debian.tar.xz
Files:
 1a82222da95d823184a27d22f2dff159 3585 web optional 
webkit2gtk_2.10.8-1ubuntu1.dsc
 252aad5319aa59d940b3d8161c5a9dc0 10994340 web optional 
webkit2gtk_2.10.8.orig.tar.xz
 63313327c28cece4b2f31b60e4f18a45 55100 web optional 
webkit2gtk_2.10.8-1ubuntu1.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJW5/1TAAoJEONS1cUcUEHUaFoP/RAUCLTH7HOGKSw5bufus1R+
1pnq5kNs4JvFX5ILpJDQUBFM1mjD5Pt/UsCe2+Hep8Izpt++t87IroIJ8SqcOYgQ
jM09TQUL8WDNDe/vCS2EnKmvKKKNTSC6ysXkEV+6Me+SiYKdzCDD+ZdRRM8yJ8gd
ptyFZqTq0oIFuyShOQpgFNh6aBk/vLhpzScZCjOe3L6ynTSjgjlqkD3aYutk2wBC
Dvwzr/Wqk4uMoIuJ5msWTgq6dtbDWXRrg0fCEWhBNubhf49t1f5jz8FNoBW+3DT2
a93P0gYjYVMkc4dNNVoFOvS/nWQjg7w49KjOdtkD8EduXNK0/Rly+C++VaODMLpx
omPQqtUSyPqveFPwhe8vfWB2j5NBmjvHoE+pak8dErISQLhVaTOmw81btKbvYAg6
oco2xSs7aDDXieGCarVYGzQuIOyXbSz/bh5slN7Oh82jO4PnOJ5h/gGQnJbt8CeW
ozaAJSpH81UR0qUSm2zqQMgtrrlkC+eleiHiaQBBRjBWZE+MrsQ5HiIhdzUvNV67
uxYjz/4Ed33LrXDL8kt1YmqOguTsVAHEG8O2KgSX03WrqsPyygvUUH7nzidBnvaT
aHkIjCSmIKTKGTlyJG9M/gJDbe0E8JqCcZi3eceVBfvDIP4113pMPD/nxWPzfs3F
NSWRPEuTy1sNBhswHbGh
=Vhan
-----END PGP SIGNATURE-----
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to