botch (0.17-3) unstable; urgency=medium

  * Allows one to only build architecture dependent or architecture
    independent packages (Closes: #804296)
      - build dependencies are selected through Build-Depends-Arch and
        Build-Depends-Indep
      - this only fixes #804296 because it will not build the failing
        wiki target anymore during architecture dependent builds on mips or
        mipsel. The real fix still has to be done in #804297. The problem is
        hidden because Architecture:all packages are not built on mips or
        mipsel.
  * support for DEB_BUILD_PROFILES nodoc and nocheck
  * support for DEB_BUILD_OPTIONS nodoc and nocheck

botch (0.17-2) unstable; urgency=medium

  * backport two patches from upstream git to support running the misc unit
    test target on non-native architectures:
       - 797639f Makefile: do not add debug information by default on
         non-native architectures, move that to a new debug target
       - bc22129 tools/*.sh: check all possible ocaml extensions to find an
         executable

botch (0.17-1) unstable; urgency=medium

  * new upstream release
  * The upload of clasp 3.1.3-1 broke aspcud in some cases (see #800526 and
    #801169) and introduced a spurious failure of the test suite that was
    worked around with the upload of upstream version 0.16. Now that the
    problem is known and clasp was fixed with 3.1.3-2, this upstream release
    reverts that change (closes: #802265).
  * remove debian/patches/print-stats.ml-do-not-use-yojson.safe.pr because
    that commit is part of this upstream release
  * refresh debian/patches/send-keepalive
  * add debian/tests/misc
  * add build dependency on python3-pydot for the test suite
  * add build dependency on gsfonts because graphviz wants a font called
    "Times-Roman" and otherwise falls back to "DejaVu Serif" instead of using
    "Nimbus Roman No9 L" with gsfonts installed. This could've also been
    fixed by changing the testcase png be rendered using "DejaVu Serif"
  * add build dependency on libgraph-easy-perl for the graph-easy tool which
    is needed by y-u-b-d-transitive-essential in the test suite
  * break long lines in debian/control for extended description
  * add additional Depends for debian/tests/control for the misc test

Date: 2015-11-08 22:17:15.495742+00:00
Signed-By: Steve Langasek <steve.langa...@canonical.com>
https://launchpad.net/ubuntu/+source/botch/0.17-3
Sorry, changesfile not available.
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to