python-pip (8.1.1-2ubuntu0.1) xenial; urgency=medium

  * d/patches/editable-mode.patch: Cherry pick upstream fixes for crash
    when pip installing in editable mode.  (LP: #1578761)
  * d/tests:
    - pip3-editable.sh: Added to prove the crash is fixed.
    - control: Updated
    - *.sh: export PIP_DISABLE_PIP_VERSION_CHECK=1 to prevent stderr
      warnings (and thus test failures) because of the newer upstream.
  * d/control:
    - Add python3-pyparsing as a new Build-Depends as this is required
      for the cherry picked fix.
    - Update the python-colorama and python-setuptools Built-Using versions.
    - Add pyparsing to Built-Using.
    - update-maintainer
  * d/rules: dirtbike up pyparsing.

Date: Thu, 05 May 2016 16:11:04 -0500
Changed-By: Barry Warsaw <ba...@ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/python-pip/8.1.1-2ubuntu0.1
Format: 1.8
Date: Thu, 05 May 2016 16:11:04 -0500
Source: python-pip
Binary: python-pip python3-pip python-pip-whl
Architecture: source
Version: 8.1.1-2ubuntu0.1
Distribution: xenial
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Changed-By: Barry Warsaw <ba...@ubuntu.com>
Description:
 python-pip - alternative Python package installer
 python-pip-whl - alternative Python package installer
 python3-pip - alternative Python package installer - Python 3 version of the pa
Launchpad-Bugs-Fixed: 1578761
Changes:
 python-pip (8.1.1-2ubuntu0.1) xenial; urgency=medium
 .
   * d/patches/editable-mode.patch: Cherry pick upstream fixes for crash
     when pip installing in editable mode.  (LP: #1578761)
   * d/tests:
     - pip3-editable.sh: Added to prove the crash is fixed.
     - control: Updated
     - *.sh: export PIP_DISABLE_PIP_VERSION_CHECK=1 to prevent stderr
       warnings (and thus test failures) because of the newer upstream.
   * d/control:
     - Add python3-pyparsing as a new Build-Depends as this is required
       for the cherry picked fix.
     - Update the python-colorama and python-setuptools Built-Using versions.
     - Add pyparsing to Built-Using.
     - update-maintainer
   * d/rules: dirtbike up pyparsing.
Checksums-Sha1:
 1f5b6aca64ef8bcd35441db7f28590ae957432be 2729 python-pip_8.1.1-2ubuntu0.1.dsc
 0f9473b5c7eef38d3d9fccb829d9842ad43374a2 18080 
python-pip_8.1.1-2ubuntu0.1.debian.tar.xz
Checksums-Sha256:
 d7f3e1447cfefca4d63a578ffd271787e8bc155c4a7327c57f4bd4787e4fd2a2 2729 
python-pip_8.1.1-2ubuntu0.1.dsc
 d1f01413d48ff8ef539298feca7465990b43b1731bef4bada3e3cb1d9429a2fa 18080 
python-pip_8.1.1-2ubuntu0.1.debian.tar.xz
Files:
 2741b99f0e3661aaf8fd09a28b14a0c5 2729 python optional 
python-pip_8.1.1-2ubuntu0.1.dsc
 de831e555d5c1d99877b38919da57c61 18080 python optional 
python-pip_8.1.1-2ubuntu0.1.debian.tar.xz
Original-Maintainer: Debian Python Modules Team 
<python-modules-t...@lists.alioth.debian.org>
-- 
Xenial-changes mailing list
Xenial-changes@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/xenial-changes

Reply via email to