Ian Norton-Badrul wrote:
> Hi Alex,
>
> I belive the xmlrpc server listens on port 8006
>   

Apparently not as if I comment the line "(xend-tcp-xmlrpc-server yes)" 
there is no more 8005 port listening according to netstat, in addition 
xenman specify a port in the dialog box when you add a new node which is 
8005 by default

Any other Idea?

Do  you (or anyone else) have it working with debian and xen 3.0.3?
> Ian
>
> On Wed, Mar 21, 2007 at 03:01:17PM +0100, Alexandre Chapellon wrote:
>   
>>    Ian Norton-Badrul wrote:
>>
>>  Hi Alex,
>>
>>
>>
>>    Hi and first thanks for this fast answer
>>
>>  What version of xen are you running on your remote system? And are you
>>  sure that machine has the xml rpc server running?
>>
>>
>>    I'm running Xen 3.0.3-1 (debian package)
>>    And I have activated xml rpc as show below:
>>    (xend-tcp-xmlrpc-server yes)
>>
>>    By the way netstat shows its listenning on lo:8005... as you can see
>>
>>    ~#netstat -tan
>>    Connexions Internet actives (serveurs et etablies)
>>    Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat
>>    tcp        0      0 0.0.0.0:8000            0.0.0.0:*               LISTEN
>>    tcp        0      0 0.0.0.0:8002            0.0.0.0:*               LISTEN
>>    tcp        0      0 127.0.0.1:8005          0.0.0.0:*               LISTEN
>>    tcp        0      0 0.0.0.0:9102            0.0.0.0:*               LISTEN
>>    tcp6       0      0 :::22                   :::*                    LISTEN
>>    tcp6       0    128 ::ffff:172.20.255.60:22 ::ffff:172.30.0.1:37519
>>    ESTABLISHED
>>
>>    Am I right?
>>
>>  Ian
>>
>>  On Wed, Mar 21, 2007 at 01:59:49PM +0100, Alexandre Chapellon wrote:
>>
>>
>>  Hy all!
>>
>>  I'm interresting in using xenman to manage my Domain0 and and domU upon
>>  several machines.
>>  Unfortunatly, when I try to connect to a remote node I get a Domain0 not
>>  found in the gui and the following error in the console where I launch
>>  xemna (using sudo xenman):
>>
>>  got expat error  no element found: line 1, column 0
>>
>>  The localhost seems to be working but not the remote ones...
>>
>>  I have configured ssh so that It uses login/pass to connect and tcpdump
>>  shows traffic on the loopback interface when I connect:
>>
>>  16:02:06.662754 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 53 win 4099
>>  <nop,nop,timestamp 106887986 106887986>16:02:06.662853 IP 127.0.0.1.8005
>>   > 127.0.0.1.1134: P 53:90(37) ack 298 win 4096 <nop,nop,timestamp
>>  106887986 106887986>
>>  16:02:06.662860 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 90 win 4099
>>  <nop,nop,timestamp 106887986 106887986>16:02:06.662920 IP 127.0.0.1.8005
>>   > 127.0.0.1.1134: P 90:114(24) ack 298 win 4096 <nop,nop,timestamp
>>  106887986 106887986>
>>  16:02:06.662926 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 114 win 4099
>>  <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.662984 IP 127.0.0.1.8005 > 127.0.0.1.1134: P 114:136(22) ack
>>  298 win 4096 <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.662991 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 136 win 4099
>>  <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.663036 IP 127.0.0.1.8005 > 127.0.0.1.1134: P 136:138(2) ack 298
>>  win 4096 <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.663042 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 138 win 4099
>>  <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.663083 IP 127.0.0.1.8005 > 127.0.0.1.1134: P 138:2339(2201) ack
>>  298 win 4096 <nop,nop,timestamp 106887986 106887986>
>>  16:02:06.663089 IP 127.0.0.1.1134 > 127.0.0.1.8005: . ack 2339 win 4650
>>  <nop,nop,timestamp 106887986 106887986>
>>
>>
>>  What did I miss?
>>
>>  -------------------------------------------------------------------------
>>  Take Surveys. Earn Cash. Influence the Future of IT
>>  Join SourceForge.net's Techsay panel and you'll get the chance to share your
>>  opinions on IT & business topics through brief surveys-and earn cash
>>  [1]http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
>>  _______________________________________________
>>  XenMan-Users mailing list
>>  [EMAIL PROTECTED]
>>  [3]https://lists.sourceforge.net/lists/listinfo/xenman-users
>>
>>
>> References
>>
>>    Visible links
>>    1. 
>> http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
>>    2. mailto:XenMan-Users@lists.sourceforge.net
>>    3. https://lists.sourceforge.net/lists/listinfo/xenman-users
>>     

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
XenMan-Users mailing list
XenMan-Users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xenman-users

Reply via email to