Jan Kiszka wrote:
Hi Philippe,

I noticed you fixed the libtool warning during xenomai build - by
linking the testsuite statically... :-/ This is just a workaround and
doesn't help external users.

Yes, it's clearly hacky-patchy, however, I don't see how this would impact external users (yet)?

Isn't the reason for this warnings that "-module" in every skin
Makefile.am? At least, removing it also fixes external apps. Do we need
it? I don't think so: -module is for preparing dlopen usage, but who
will use it with skin libs?

E.g. People who need to do late binding from some interpreter engine to the routines defined by those APIs.



Xenomai-core mailing list

Reply via email to