Sebastian Smolorz wrote:
> Jan Kiszka wrote:
>> Sebastian Smolorz wrote:
>>> Jan Kiszka wrote:
>>>> Sebastian Smolorz wrote:
>>>>> The possibility of redefinition was not the main goal here. As you
>>>>> mentioned it would be problematic. No, I introduced nanosecs_abs_t and
>>>>> nanosecs_rel_t because they are more intuitive and more "speaking" to
>>>>> the programmer. The meaning of a variable of such a type is clear at
>>>>> first sight.
>>>> Yeah, sounds reasonable to me. Then let's move these typedefs to rtdm.h
>>>> and document them as self-explanatory defines of the underlying standard
>>>> types, freezing their width and signedness at the same time.
>>> Agreed.
>>>> Actually, this would be useful for the driver API of RTDM as well.
>>> That's right. No objections from my side.
>> Done.
>> Though I checked things more then twice, some regression may be hidden,
>> specifically as I changed the signedness of timeout parameters of a few
>> RTDM driver API functions. All documented under
>> ksrc/skins/rtdm/API.CHANGES, and everyone is warned now.
> Here comes a follow-up patch. Compile-tested successfully.

Just applied, thanks.

[I thought about dropping the RTSER_TIMEOUT_* stuff as well, but A)
there are already users and B) it aligns so well with the other defines
for rtser_config.]


Xenomai-core mailing list

Reply via email to