On Tue, 2006-09-19 at 09:48 -0500, Jeff Webb wrote:
> Jeff Webb wrote:
> > I don't have a plain xenomai-2.2.2 kernel handy, but I do have a patched 
> > version.  I do not have any problems with switchtest for xenomai-2.2.2 
> > with the following patches:
> > 
> >  https://mail.gna.org/public/xenomai-help/2006-09/msg00084.html
> >  https://mail.gna.org/public/xenomai-help/2006-09/msg00096.html
> > 
> > These patches are to nucleus pipe.c and pipe.h / rtai fifo.c and fifo.h.
> > 
> > I am running an Athlon64 X2 in with 32-bit Fedora Core 5.
> 
> I have done a couple more tests using xenomai from subversion.  Here is a 
> summary of all the results I have so far:
> 
> xenomai-2.2.2 (patched as described above): switchtest runs
> svn/xenomai/trunk (r1586): switchtest runs
> svn/xenomai/trunk (r1589): switchtest runs
> xenomai-2.2.3 : switchtest fails
> 
> This is on my Fedora Core 5 (32-bit x86), linux-2.6.17.13 SMP, ipipe-1.3 
> (except 1.4 for 2.2.3), gcc-4.1.1, Athlon64 X2.
> 
> Hopefully this will help,

It does, thanks. This confirms Jan's findings that something went wrong
from #1595. The issue is spotted now, somewhere in the FPU save/restore
code in the x86 support layer.

> 
> -Jeff
> 
> 
> _______________________________________________
> Xenomai-core mailing list
> Xenomai-core@gna.org
> https://mail.gna.org/listinfo/xenomai-core
-- 
Philippe.



_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to