Stelian Pop wrote:
 > Hi,
 > 
 > The attached patch adds an option to make Xenomai userspace issue EABI
 > syscalls. This is needed to make Xenomai work with kernels compiled with
 > CONFIG_EABI.
 > 
 > Note that due to a change in syscall handling when the EABI layer was
 > added in the kernel, this patch is needed for all EABI enabled kernels,
 > even if the CONFIG_OABI_COMPAT compatibility layer has been enabled.
 > 
 > All sensible combinations should be supported: old ABI userspace with
 > old ABI kernel, old ABI userspace with CONFIG_OABI_COMPAT kernels, EABI
 > userspace with EABI kernels. The other combinations will fail with a
 > SIGILL signal.
 > 
 > Don't forget to run 'scripts/bootstrap' after applying this patch...

Applied, thanks. And by the way, I am running Debian Etch, and its
version of autotools seems to complain that we do not use datarootdir in
xeno-config.in... 

-- 


                                            Gilles Chanteperdrix.

_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to