On 10/1/07, Patrick <[EMAIL PROTECTED]> wrote:
> > -----Message d'origine-----
> > De: Gilles Chanteperdrix [mailto:[EMAIL PROTECTED]
> > Envoyé: lundi, 1. octobre 2007 15:11
> > À: Patrick
> > Cc: xenomai-core
> > Objet: Re: [Xenomai-core] ARM compiling error
> > > On 10/1/07, Patrick <[EMAIL PROTECTED]> wrote:
> > > > On 10/1/07, Patrick <[EMAIL PROTECTED]> wrote:
> > > > >
> > > > > I install Xenomai 2.3.4 for ARM on 2.6.20 kernel. The prepare-kernel
> > > > > script
> > > > > work well.
> > > >
> > > > Which ARM machine ?
> > > > Which version of the ARM patch ?
> > > > From your compilation log, I would say that you are using an I-pipe
> > > > patch which is older than Xenomai v2.3.4, so the general advice is to
> > > > use the I-pipe patch which comes with the version of Xenomai you use.
> > >
> > > I use an ARM PXA270 and adeos-ipipe-2.6.20-arm-1.7-05.
> > >
> > > I use the latest stable version of Xenomai (2.3.4) and the latest version
> > of
> > > ipipe for ARM (1.7).
> >
> > The I-pipe patch which comes with Xenomai (2.3.4) is
> > adeos-ipipe-2.6.20-arm-1.7-06, you will find it in the
> > ksrc/arch/arm/patches subdirectory of Xenomai sources. If you call
> > prepare-kernel without any argument it will pick the right patch.
> >
> > Please do send your replies to the mailing list.
>
> I have already tried this (with arm-1.7-05 from adeos website and arm-1.7-06
> from xenomai/ksrc/arch/arm/patches) but the result is the same.

I have just tried to build Xenomai-2.3.4 for PXA 270 (LogicPD PXA270
Card Engine Development Platform), and it builds flawlessly. So, I
suggest you erase everything, and restart from clean sources, use
I-pipe for ARM version 1.7-06, and nothing else.

-- 
                                               Gilles Chanteperdrix

_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to