Jan Kiszka wrote:
> In order to allow further optimizations of xnlock, I started with
> refactoring the related system.h. This improves the readability
> significantly, IMHO. It also happen to reduce the text size of
> __xnlock_get a bit by avoid redundant rthal_processor_id read-outs.
> Another quirk I happen to remove: xnlock debugging depends on
> XENO_OPT_DEBUG_NUCLEUS, but needlessly we used to pick the debug version
> of xnlock_t already with XENO_OPT_DEBUG.
There is a lot of whitespace change in this patch, which make it hard to
Anyway, there are a few things I do not like in this patch:
- macro which make reference to symbols defined elsewhere
- functions arguments as macro, I find more readable the #ifdef with the
different function prototypes, the code can be read without having to
look at a different place.
Something we could be interesting would be to be able to enable
spinlocks debug in UP, which would enable real debugging xnlocks in this
case. I made an attempt of doing this on ARM some time ago, this
generated a kernel that would lockup at boot. But I think this is
something we should sort out.
Xenomai-core mailing list