It looks like this patch is still pending an ack/nak. Wolfgang, any
comment on this? TIA,

On Tue, 2009-05-05 at 21:04 +0200, Stefan Kisdaroczi wrote:
> Hi,
> 
> my pci board has the same pci-interface-chip as the IXXAT-PCI board.
> The vendor and device id's are identical, but the subsys id is different.
> 
> The documentation for my board says that it is essential to check all ID 
> values,
> because vendor and device id are standard values for the pci-interface-chip.
> 
> dmesg output, there is no IXXAT-PCI-CAN board installed:
> > RT-Socket-CAN 0.90.2 - (C) 2006 RT-Socket-CAN Development Team
> > RTCAN SJA1000 driver initialized
> > PCI: setting IRQ 12 as level-triggered
> > IXXAT-PCI-CAN 0000:00:11.0: found PCI INT A -> IRQ 12
> > IXXAT-PCI-CAN: Initializing device 10b5:9050:2503
> 
> The following patch fixed it for me (my own driver loads again).
> However, i could not check if it still detects the CAN board,
> as i dont have one.
> 
> Thanks
> kisda
> 
> --- xenomai-2.4.7.orig/ksrc/drivers/can/sja1000/rtcan_ixxat_pci.c
> +++ xenomai-2.4.7/ksrc/drivers/can/sja1000/rtcan_ixxat_pci.c
> @@ -73,7 +73,7 @@
>  #define IXXAT_BASE_PORT_SIZE 0x0400
> 
>  static struct pci_device_id ixxat_pci_tbl[] = {
> -     {IXXAT_PCI_VENDOR_ID, IXXAT_PCI_DEVICE_ID, PCI_ANY_ID, PCI_ANY_ID, 0, 
> 0, 0},
> +     {IXXAT_PCI_VENDOR_ID, IXXAT_PCI_DEVICE_ID, IXXAT_PCI_VENDOR_ID, 
> IXXAT_PCI_SUB_SYS_ID, 0, 0, 0},
>       { }
>  };
>  MODULE_DEVICE_TABLE (pci, ixxat_pci_tbl);
> 
> 
> _______________________________________________
> Xenomai-help mailing list
> xenomai-h...@gna.org
> https://mail.gna.org/listinfo/xenomai-help
-- 
Philippe.



_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to