On Wed, 2010-08-18 at 17:43 +0200, Gilles Chanteperdrix wrote:
> Krzysztof Błaszkowski wrote:
> > On Wed, 2010-08-18 at 17:13 +0200, Gilles Chanteperdrix wrote:
> >> Krzysztof Błaszkowski wrote:
> >>> On Wed, 2010-08-18 at 16:30 +0200, Gilles Chanteperdrix wrote:
> >>>> Krzysztof Błaszkowski wrote:
> >>>>> On Wed, 2010-08-18 at 16:10 +0200, Gilles Chanteperdrix wrote:
> >>>>>> Krzysztof Błaszkowski wrote:
> >>>>>>> yes. i downloaded this config a while ago. need to setup new kernel
> >>>>>>> 2.6.31.1 with xenomai. 
> >>>>>>> is 2.5.4 suitable for this test ? 
> >>>>>>> should i also use adeos-*.31.1-*2.4-09 patch ?
> >>>>>> See the versions I posted in my test report yesterday. They were made
> >>>>>> with this configuration.
> >>>>>>
> >>>>> ok. kernel 2.6.31.8, 2.5.4, ht will be enabled,
> >>>>>
> >>>>> for xenomai's configure i will pass following switches:
> >>>>> --enable-x86-sep --enable-x86-tsc --enable-smp
> >>>>>
> >>>>> is this okay ?
> >>>> Yes.
> >>>>
> >>> bingo !
> >>>
> >>> atest:~/xeno-test-254-2 # ./.try.sh 
> >>> main:79 heap 0x401b1000
> >>> /root/xeno-test-254-2
> >>> main:96 [823] pid 825
> >>> main:89
> >>> main:90 [825] pid 0
> >>> main:99 [823] pid 825, status 00000b00
> >>> main:100 [823] pid 825, WIFSIGNALED 0, WIFEXITED 1, rc 11
> >>> 0
> >>> atest:~/xeno-test-254-2 # uname -a
> >>> Linux atest 2.6.31.8-xeno254-smp-ht #1 SMP Wed Aug 18 17:04:00 CEST 2010
> >>> i686 i686 i386 GNU/Linux
> >>>
> >>>
> >>> my fork() test works now with kernel configured with your config.
> >>>
> >>> so this try proves no doubt that userland (libc, pthreads and so on)
> >>> work.
> >>>
> >>> and i guess that this memory corruption which caused fork to die inside
> >>> libc can be something specific to UP configuration. (i was thinking
> >>> about using my config with smp this time)
> >>>
> >>> Thank you for sending me kernel configuration which pointed out an area
> >>> which should be searched further.
> >> Yes, now if you find the culprit option, it would be nice to report here
> >> so that we can fix the I-pipe patch.
> >>
> > 
> > okay. will try to dig up.
> 
> As a first quick test, could you try and disable CONFIG_AUDITSYSCALL ?
> 


seems that without "auditsyscall" fork dies too.

-- 
Krzysztof Blaszkowski


_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to