Yes, you are right, it is ok for 2.6.35-x86-trace.Thank you very much.

2011/9/5 Jan Kiszka <jan.kis...@web.de>

> On 2011-09-05 04:32, rainbow wrote:
> > hi,
> > I did a test for ftrace-xenomai on x86_64 test just now:
> > the environment is : OS: debian 6.0 gcc-4.1
> > I use origin/queues/2.6.37-x86 branch on git
> > git://git.kiszka.org/ipipe-2.6for linux kernel and use branch
> > origin/queues/ftrace on git git://
> > git.xenomai.org/xenomai-jki.git
> > then I do as the following procedures:
> > 1,cd xenomai git
> > 2, ./scripts/prepare-kernel.sh --arch=x86_64 --linux=path_to_2.6.37-x86
> > 3, cd path_to_2.6.37_x86
> > 4,make menuconfig
> > then enble ftrace on kernel hacking option.
> > 5,install the kernel and reboot the machine.
> > 6,do ftrace test
> > 6.1 mount -t debugfs nodev /sys/kernel/debug
> > 6.2 cd /sys/kernel/debug/tracing
> > 6.3 echo function > current_tracer
> > At last the machine reboot.
> > Is there something wrong about the above procedure? Thanks!
>
> Only queues/2.6.35-x86-trace contains ftrace support.
>
> Jan
>
>


-- 
Qingquan Lv
School of Information Science & Engineering , Lanzhou University.
mail: lvq...@gmail.com
Do what you like,
Enjoy your life.
_______________________________________________
Xenomai-core mailing list
Xenomai-core@gna.org
https://mail.gna.org/listinfo/xenomai-core

Reply via email to