Module: xenomai-rpm
Branch: for-upstream
Commit: 6df03f572fa432bed3b53b8cc9a80369a71a3c03
URL:    
http://git.xenomai.org/?p=xenomai-rpm.git;a=commit;h=6df03f572fa432bed3b53b8cc9a80369a71a3c03

Author: Philippe Gerum <r...@xenomai.org>
Date:   Wed Jun 16 08:33:33 2010 +0200

rtai: disable for MMU-less and 64bit builds

This emulator is massively broken on those platforms, and fixing it
would require an ABI change, which would make no sense given that it
is on its way out.

---

 ksrc/skins/rtai/Kconfig |    8 ++++++--
 1 files changed, 6 insertions(+), 2 deletions(-)

diff --git a/ksrc/skins/rtai/Kconfig b/ksrc/skins/rtai/Kconfig
index ac411eb..2555354 100644
--- a/ksrc/skins/rtai/Kconfig
+++ b/ksrc/skins/rtai/Kconfig
@@ -1,10 +1,14 @@
 menuconfig XENO_SKIN_RTAI
-       depends on XENO_OPT_NUCLEUS
-       tristate "RTAI emulator (DEPRECATED)"
+       depends on XENO_OPT_NUCLEUS && MMU && WORD_SIZE != 64
+       tristate "RTAI emulator (BROKEN, DEPRECATED)"
        help
 
        An emulator of the RTAI system.
 
+       This emulator is actually broken beyond all recognition:
+       - on MMU-less targets
+       - on 64bit targets
+
        WARNING: This emulator is DEPRECATED. It is planned for
        removal in v2.6.x. Legacy applications depending on it should
        be converted to the native Xenomai API, which provides


_______________________________________________
Xenomai-git mailing list
Xenomai-git@gna.org
https://mail.gna.org/listinfo/xenomai-git

Reply via email to