Module: xenomai-rpm
Branch: for-upstream
Commit: bebc2a8e6b430c99041800330dc6061665371d90
URL:    
http://git.xenomai.org/?p=xenomai-rpm.git;a=commit;h=bebc2a8e6b430c99041800330dc6061665371d90

Author: Philippe Gerum <r...@xenomai.org>
Date:   Sat Jun 18 10:32:17 2011 +0200

nucleus/shadow: disable u_mode watchdog for 2.4.x kernels

The u_mode consistency watchdog has false positive triggers due to
obsolete glibc limitations wrt pthread key deletion upon app
exit.

Disable the u_mode watchdog when a 2.4.x kernel is detected, assuming
an old glibc is likely at work as well.

---

 ksrc/nucleus/shadow.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/ksrc/nucleus/shadow.c b/ksrc/nucleus/shadow.c
index 925f1c7..f7407e9 100644
--- a/ksrc/nucleus/shadow.c
+++ b/ksrc/nucleus/shadow.c
@@ -2230,7 +2230,7 @@ static void handle_shadow_exit(void)
         */
        if (thread->u_mode && !warned) {
                warned = 1;
-#ifdef CONFIG_MMU
+#if defined(CONFIG_MMU) && LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
                printk(KERN_WARNING
                       "Xenomai: User-space support anterior to 2.5.2"
                       " detected, may corrupt memory upon\n"


_______________________________________________
Xenomai-git mailing list
Xenomai-git@gna.org
https://mail.gna.org/listinfo/xenomai-git

Reply via email to